[RTL][Dialer]The incoming call icon is not left-aligned.

VERIFIED FIXED in Firefox OS v2.2

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: thills)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l][planned-sprint c=1])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8573112 [details]
incoming_call_icon.png

[1.Description]:
[RTL][Dialer]The incoming call icon is right-aligned and at right side of number.
See attachment:incoming_call_icon.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic and insert a SIM card.
1. Launch Phone.
2. MO a call.
3. MT a call from another device to test device.
4. Observe the incoming call.

[3.Expected Result]: 
4. The incoming call number should be right-aligned and incoming call icon should be left-aligned.

[4.Actual Result]: 
4. The incoming call icon is right-aligned and at right side of number.

[5.Reproduction build]: 
Nexus 5:
Build ID               20150303002527
Gaia Revision          3d188c414e30acc392253d5389a42352fcfbc183
Gaia Date              2015-03-03 00:53:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c89aad487aa5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150303.040940
Firmware Date          Tue Mar  3 04:09:55 EST 2015
Bootloader             HHZ12d
Device Name            hammerhead

Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Triage P2 - Nominating since this is inconsistent with the rest of RTL behavior
blocking-b2g: --- → 2.2?
Priority: -- → P2
Whiteboard: [2.2-nexus-5-l]
Hi Sue, is this also reproducible on flame? If so, we will need to update the subject.
Flags: needinfo?(lulu.tian)
according to the description, it seems reproducible on Flame.
triage: issue on new feature RTL
blocking-b2g: 2.2? → 2.2+
(Reporter)

Comment 4

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #2)
> Hi Sue, is this also reproducible on flame? If so, we will need to update
> the subject.

Yes, this issue also reproducible on Flame 2.2/3.0
Flags: needinfo?(lulu.tian)
Summary: [RTL][Nexus 5][Dialer]The incoming call icon is not left-aligned. → [RTL][Dialer]The incoming call icon is not left-aligned.
Assignee: nobody → thills
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][planned-sprint c=1]
Target Milestone: --- → 2.2 S8 (20mar)
(Assignee)

Comment 5

4 years ago
Created attachment 8574882 [details] [review]
PR
Attachment #8574882 - Flags: review?(gsvelto)

Updated

4 years ago
Status: NEW → ASSIGNED
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/15510/
Flags: in-moztrap+
Comment on attachment 8574882 [details] [review]
PR

This doesn't seem to fix the problem completely, only if the contact has some additional information. Otherwise the selector here kicks in and moves the icon back on the right side:

https://github.com/mozilla-b2g/gaia/pull/28729/files#diff-2d7ff3a2c8f06917d181bf785dc947d8R729
Attachment #8574882 - Flags: review?(gsvelto) → review-
(Assignee)

Comment 8

4 years ago
Comment on attachment 8574882 [details] [review]
PR

Hi Gabriele,

Thank you, good catch!  Here is an updated PR which I squashed with the prev one since it's pretty small patch.

Thanks,
-tamara
Attachment #8574882 - Flags: review- → review?(gsvelto)
Comment on attachment 8574882 [details] [review]
PR

Looks good to me!
Attachment #8574882 - Flags: review?(gsvelto) → review+
(Assignee)

Comment 11

4 years ago
Comment on attachment 8574882 [details] [review]
PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL feature
[User impact] if declined: an RTL user would see the incoming call icon on the wrong side of the screen.  It could be confusing
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky):Low
[String changes made]:none
Attachment #8574882 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

4 years ago
Attachment #8574882 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Reporter)

Comment 12

4 years ago
Created attachment 8579096 [details]
verify.png

This issue has been verified successfully on Flame 3.0, the incoming call number is right-aligned and incoming call icon is left-aligned.
See attachment:verify.png
Rate:0/3

Flame 3.0 build: pass
Build ID               20150317073344
Gaia Revision          738987bd80b0ddb4ccf853855388c2627e19dcc1
Gaia Date              2015-03-17 02:27:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/008b3f65a7e0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.111450
Firmware Date          Tue Mar 17 11:15:00 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8581372 [details]
Verify2_Flame2.2_Pass.png

This issue has been verified successfully on latest Flame 2.2 build.
See attachment: Verify2_Flame2.2_Pass.png
Reproducing rate:0/10 

Flame 2.2 build:
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 15

4 years ago
Created attachment 8581373 [details]
verify_v2.2.png

This issue has been verified successfully on Flame 2.2, the incoming call number is right-aligned and incoming call icon is left-aligned.
See attachment:verify_v2.2.png
Rate:0/3

Flame 2.2 build: pass
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.