[RTL][Dialer] Carat of ICE Contacts is mirrored when we make an Emergency call.

RESOLVED INVALID

Status

defect
P3
normal
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted image carat.png
[1.Description]:
[RTL][Dialer]Carat of ICE Contacts is mirrored and shown as "<" when we make an Emergency call.
See attachment:carat.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic and set a ICE Contacts.
1. Launch Settings -> Screen Lock.
2. Enable Lock Screen and Passcode Lock.
3. Double press power key to lock screen.
4. Slide right to input password.
5. Tap "EMERGENCY CALL" and observe the carat of ICE Contacts.

[3.Expected Result]: 
5. The carat should be left-aligned but not mirrored(should be shown as ">").

[4.Actual Result]: 
5. The carat is mirrored and shown as "<".

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
I believe this also should be fixed when Bug 1132230 is resolved on 2.2 and master
Depends on: 1132230
Since the call screen drops down from the top anyway I don't think the direction of the caret has any impact here.
Priority: -- → P3
Reporter

Comment 3

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15525/
Flags: in-moztrap+
Reporter

Comment 4

4 years ago
(In reply to Delphine Lebédel [:delphine - in SA for l10n events until April 7th, expect delay in answering] from comment #1)
> I believe this also should be fixed when Bug 1132230 is resolved on 2.2 and
> master

Hi Dylan,
Bug 1132230 had been verified successfully on Flame 2.2/3.0, but this bug is not fixed on latest build of Flame 2.2/3.0, I have uploaded the screenshot, could you help with it? Thanks!
See attachment:incorrect_carat.png
Rate:5/5
Device: Flame 2.2 (affected)
Device: Flame 3.0 (affected)
Reporter

Comment 5

4 years ago
Posted image incorrect_carat.png
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Reporter

Updated

4 years ago
Whiteboard: MGSEI-RTL-3F
Ok this means this was unrelated to the fix in Bug 1132230.
As Dylan pointed out, this is a minor issue. Let's keep this as a P3 and teams can get to it when they can
Reporter

Updated

4 years ago
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F,[2.2-nexus-5-l]
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F,[2.2-nexus-5-l] → [2.2-nexus-5-l]
his issue can be reproduced on latest build of AriesKK_V2.5.
Rate:5/5
Device:AriesKK_V2.5
Build ID               20150811150203
Gaia Revision          2d7f369fd923b6df3b00d76844c413c1202c04ba
Gaia Date              2015-08-11 09:58:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.182056
Firmware Date          Tue Aug 11 18:21:06 EDT 2015
Bootloader             L1TC000118D0
Blocks: 1181927
As of new 2.5 rtl specs, all the arrows are now mirrored. Closing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.