[RTL][Search]The scroll bar disappeared when user searches results via Rocket bar.

VERIFIED DUPLICATE of bug 1129701

Status

defect
P1
normal
VERIFIED DUPLICATE of bug 1129701
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: daleharvey)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Posted video video.MP4
[1.Description]:
[RTL][Search]When user searches results via Rocket bar, scroll down/up the results, there is no scroll bar.
See attachment:video.MP4

[2.Testing Steps]: 
1. Set your phone language to Arabic and connect the network. 
2. Tap the Rocket bar. 
3. Input the keywords. 
4. Scroll down/up the search result.

[3.Expected Result]: 
4. The scrollbar should be left-aligned and still move vertically. 

[4.Actual Result]: 
4. There is no scroll bar.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150304002529
Gaia Revision          8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gaia Date              2015-03-03 15:01:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cb52b7cda5a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.042036
Firmware Date          Wed Mar  4 04:20:47 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150304010324
Gaia Revision          3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gaia Date              2015-03-03 21:58:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c5b90c003be8
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150304.041952
Firmware Date          Wed Mar  4 04:20:03 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15445
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Whiteboard: [systemsfe]
This kind of issue has been triaged as P1 in other bugs. Thus triaging as such. Nminating since this happens in an often used area of the phone, and is inconsistent with rtl behavior. User might not aware that there is a list to scroll down from, since there is no scroll bar at any moment
blocking-b2g: --- → 2.2?
Priority: -- → P1
blocking-b2g: 2.2? → 2.2+
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+
dale can you take a look please?
Assignee: nobody → dale
(Assignee)

Comment 4

4 years ago
This is caused by 

  html[dir="rtl"] {
    direction: ltr;
  }

Guillaume, the deps arent fixed and not entirely sure the history about this, how should we fix it? cheers
Flags: needinfo?(gmarty)
This was removed in bug 1129701, but that got backed out. I think we should re-land bug 1129701 to solve this.
Depends on: 1129701

Updated

4 years ago
Status: NEW → ASSIGNED
Bug 489100 prevents a ::before element to be displayed on the left of its parent on RTL, so I had to keep this 'direction: ltr;' rule, unfortunately.
See also Bug 1139925 for details.
Flags: needinfo?(gmarty)
(Assignee)

Comment 8

4 years ago
Guillaume, how about we just put an actual element in there as a workaround since the platform bug isnt assigned yet?
Flags: needinfo?(gmarty)
Yeah, I preferred to keep the patch as small as possible and avoid making markup and CSS changes. But if it causes other issues, it's probably worth to be done.
Flags: needinfo?(gmarty)
(Assignee)

Comment 10

4 years ago
This was fixed by 1129701 and regressed by it being backed out, will be fixed by it being relanded so closing as dupe
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129701
ni myself for following up
Flags: needinfo?(hcheng)
(Reporter)

Comment 12

4 years ago
Posted image verify_v3.0.png
Since the patch had landed on Flame 3.0 in Bug 1129701, this issue has been verified successfully on Flame 3.0, when user searches results via Rocket bar, scroll down/up the results, the scrollbar is left-aligned and still moves vertically.
See attachment:verify_v3.0.png
Rate:0/5

Flame 3.0 build: pass
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
(Reporter)

Comment 13

4 years ago
Posted image v2.2_scrollbar.png
Since the patch had uplifted on Flame 2.2 in Bug 1129701, this issue has been verified successfully on latest build of Flame 2.2, when user searches results via Rocket bar, scroll down/up the results, the scrollbar is left-aligned and moves vertically.
See attachment:v2.2_scrollbar.png
Rate:0/5

Device: Flame 2.2(pass)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Sue, thanks!
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.