Mark as read notifications for the visible question

VERIFIED FIXED in 2015Q2

Status

support.mozilla.org
BuddyUp
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: rik, Assigned: rik)

Tracking

unspecified
2015Q2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=1 s=bu.2015.7)

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR:
1) On device A, open question 5
2) On device B, answer to question 5
3) Device A will show the new answer but won't display a notification
4) On device A, quit the application
5) On device B, answer to question 6

Actual:
Device A receives notifications for question 5 and 6.

Expected:
Device B receives notifications for question 6.
(Assignee)

Comment 1

3 years ago
This is because in step 3, we don't mark notifications for question 5 as read.

Although it could be annoying, I don't think this is a blocker for release.
I don't get it. Why do you expect Device B to get a notification? Isn't that the one who sent the message in the first place? It seems like the issue is that device A is receiving all messages as notifications still, but only when the user closes the app?

This shouldn't lead to too much confusion for helpees. People don't go around asking question after question, but it might be a major annoyance for helpers.
(Assignee)

Comment 3

3 years ago
Sorry, the expected part should read "Device A receives notifications for question 6."
We discussed this last week. Decision: We designate this not a release blocker for now. If testing shows this to be more annoying than expected we will reevaluate.
Target Milestone: --- → 2015Q2
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1154066

Updated

3 years ago
Blocks: 1149522
Whiteboard: p=1 s=bu.2015.7
(Assignee)

Updated

3 years ago
Assignee: nobody → anthony
Status: NEW → ASSIGNED
Attachment #8593880 - Flags: review?(rdalal) → review+
(Assignee)

Comment 7

3 years ago
https://github.com/mozilla/buddyup/commit/e34cd7be271855bcbb68b2b3790e141344402bf0
Flags: needinfo?(hcondei)
Flags: needinfo?(fredy)
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Flags: needinfo?(hcondei)
Status: RESOLVED → VERIFIED
Flags: needinfo?(fredy)
You need to log in before you can comment on or make changes to this bug.