ZPush Notify deadlocks on bug creation

RESOLVED DUPLICATE of bug 1138767

Status

()

RESOLVED DUPLICATE of bug 1138767
4 years ago
4 years ago

People

(Reporter: Callek, Unassigned)

Tracking

Production
x86_64
Windows 8.1

Details

(Reporter)

Description

4 years ago
While scouring logs for my service (slaveapi) I noticed this... Its not an isolated incident sadly.

slaveapi.log:2015-03-01 23:59:58,862 - INFO - t-yosemite-r5-0029 - Sending request: GET https://bugzilla.mozilla.org/rest/bug/t-y
osemite-r5-0029
slaveapi.log:2015-03-01 23:59:59,171 - INFO - t-yosemite-r5-0029 - Got response: 400
slaveapi.log:2015-03-01 23:59:59,171 - INFO - t-yosemite-r5-0029 - Couldn't find bug, creating it...
slaveapi.log:2015-03-01 23:59:59,172 - INFO - t-yosemite-r5-0029 - Sending request: POST https://bugzilla.mozilla.org/rest/bug
slaveapi.log:2015-03-02 00:00:00,073 - INFO - t-yosemite-r5-0029 - Got response: 200
slaveapi.log:2015-03-02 00:00:00,073 - ERROR - t-yosemite-r5-0029 - Something went wrong while processing!
slaveapi.log:2015-03-02 00:00:00,073 - ERROR - t-yosemite-r5-0029 - Traceback (most recent call last):
slaveapi.log:2015-03-02 00:00:00,073 - ERROR - t-yosemite-r5-0029 -

....
slaveapi.log:2015-03-02 00:00:00,076 - ERROR - t-yosemite-r5-0029 -     return self.request("POST", "bug", data)
slaveapi.log:2015-03-02 00:00:00,076 - ERROR - t-yosemite-r5-0029 -
slaveapi.log:2015-03-02 00:00:00,077 - ERROR - t-yosemite-r5-0029 - BugzillaAPIError: (u'DBD::mysql::db do failed: Deadlock found
 when trying to get lock; try restarting transaction [for Statement "REPLACE INTO push_notify(bug_id, delta_ts) VALUES(?, ?)"] at
 /data/www/bugzilla.mozilla.org/extensions/ZPushNotify/Extension.pm line 23.\n', {u'code': 100500, u'message': u'DBD::mysql::db d
o failed: Deadlock found when trying to get lock; try restarting transaction [for Statement "REPLACE INTO push_notify(bug_id, del
ta_ts) VALUES(?, ?)"] at /data/www/bugzilla.mozilla.org/extensions/ZPushNotify/Extension.pm line 23.\n', u'documentation': u'http
://www.bugzilla.org/docs/tip/en/html/api/', u'error': True})


With logs on our end going back to november the only hits of this issue I see are:

2015-03-01 23:59:59,659
2015-03-01 23:59:59,756
2015-03-02 00:00:00,077

System is set to PT:
$ date
Thu Mar  5 06:55:27 PST 2015
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1138767
You need to log in before you can comment on or make changes to this bug.