crash in js3250.dll when create or delete mail message

VERIFIED DUPLICATE of bug 106820

Status

--
critical
VERIFIED DUPLICATE of bug 106820
17 years ago
13 years ago

People

(Reporter: ericweb, Assigned: sspitzer)

Tracking

({crash})

Trunk
x86
Windows ME
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using Moz 0.9.6 on WinME: 
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6) Gecko/20011120

Don't have a reliable set of steps to reproduce, but I've seen this crash twice
todays. The symptom is that you do "something" in the mail client, and then you
get a crash alert saying that js3250.dll has crashed. 

The two "somethings" that triggered this:
1) One time, I deleted an email message (I think with the delete key) in the
inbox pane, and it crashed.
2) The other time, I tried to create a new mail message via CTRL-M, and it crashed.

Both times, I submitted stack traces via TalkBack. This was Thursday 6 December
01, and they should have been submitted under the eric@kontiki.com email address
(I think).

Could this be related to bug 53094?
(Reporter)

Updated

17 years ago
Keywords: crash
Can you give us the talkback ID # ?
(run "mozilla\bin\components\talkback.exe")
Severity: normal → critical
(Reporter)

Comment 2

17 years ago
The IDs are TB158561G and TB153288W. (Thanks for explaining how to do this.
Incidentally, the path is actually mozilla.org\Mozilla\components\talkback.exe
-- but without your hint I couldn't have figured that out!)
CC stephen for talkback TB153288W (Thanks !)

Stack Signature  JS_TypeOfValue 6703d6e5
Trigger Time 2001-12-06 20:11:25
Email Address eric@kontiki.com
URL visited opened Manage Bookmarks
User Comments deleting a mail message
Build ID 2001112012
Product ID MozillaBranch
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
JS_TypeOfValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 579]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 3599]
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 1014]
JS_ExecuteScript [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3275]
nsJSContext::ExecuteScript
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 801]
nsXULDocument::ExecuteScript
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6147]
nsXULDocument::LoadScript
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5938]
nsXULDocument::ResumeWalk
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5719]
nsXULDocument::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6105]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 137]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 614]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 177]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00688bfe
0x00058f64 
(Reporter)

Comment 5

17 years ago
Happened again (still in Moz 0.9.6 on WinME). Talkback ID is TB251452Z. What
happen ed:
1) select just-sent email message in Sent folder (I use IMAP BTW)
2) Notice that in message content area, only message body is displaying, not the
headers, which is strange.
3) Click Reply All --> crash.

Comment 6

17 years ago
Eric's most recent crash and comment is:
 "Selected just-sent email message in Sent folder. (Noticed that the message
header was not displaying in the content window, just the message body.) Clicked
Reply All. Crash."

cc'ing mscott and ducarroz.  I' not sure why the message header wouldn't be
displaying.

Eric's most recent top of stack looks like:

JS_GetPrivate [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1925]
nsJSContext::ExecuteScript
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 801]
nsXULDocument::ExecuteScript
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6147]
nsXULDocument::LoadScript
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5938]
nsXULDocument::ResumeWalk
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5719]
nsXULDocument::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6105]

Comment 7

17 years ago
This looks like a dup of http://bugzilla.mozilla.org/show_bug.cgi?id=106820
(especially the 2nd crash) which was fixed on 12/10

*** This bug has been marked as a duplicate of 106820 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified, per stack
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Comment 9

14 years ago
When attempting to submitt an email from Taxcut's website, clicking on submit
caused a JS3250.dll error. This happens every time I attempt it.

Comment 10

13 years ago
I got similar problems with a very recent release
You need to log in before you can comment on or make changes to this bug.