Closed Bug 1139963 Opened 5 years ago Closed 5 years ago

[Accessibility] Action menu dialogs are not exclusively visible to the screen reader.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S8 (20mar)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: yzen, Assigned: yzen)

References

Details

(Keywords: access)

Attachments

(2 files)

At the moment all action dialogs that are triggered view MozWebActivity are not exclusively visible to the screen reader. We need to make sure only the dialog is accessible via the screen reader.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Attachment #8579144 - Flags: review?(alive)
Comment on attachment 8579144 [details] [review]
[gaia] yzen:bug-1139963 > mozilla-b2g:master

Let's not overload AppWindowManager.

For action menu, the long term plan is move it into AppWindow.
For now, let's try this:
1. Add ActionMenu in HierarchyManager between AppWindowManager and SystemDialog.
2. register to HierarchyManager by calling |Service.request('registerHierarchy', this);| when action menu is constructed.
3. unregister to HierarchyManager by calling |Service.request('unregisterHierarchy', this);| when action menu is destructed.
4. publish ('-activated') event when action menu is opened.
5. publish ('-deactivated') event when action menu is closed.

Hence HierarchyManager will hide the active appWindow for you and we don't need to know the detail in AppWindowManager.


For Activity, we could do something like
https://github.com/mozilla-b2g/gaia/pull/28864/files
but use setVisibileForScreenReader instead.


Lemme know if you have trouble make it, Thanks.
Attachment #8579144 - Flags: review?(alive)
Comment on attachment 8579144 [details] [review]
[gaia] yzen:bug-1139963 > mozilla-b2g:master

Addressed comments, hopefully that's what you had in mind. Also, I might need to handle other popups similar to this one (bug 1069345, bug 1069348 and bug 1069347). Do you think child window factory is appropriate for that?
Attachment #8579144 - Flags: review?(alive)
Comment on attachment 8579144 [details] [review]
[gaia] yzen:bug-1139963 > mozilla-b2g:master

Great, thanks for working on this!
Attachment #8579144 - Flags: review?(alive) → review+
Keywords: checkin-needed
Sorry about the autolander trouble. Not sure if it's related to tree closure or what, but let's manually land this for now and I will investigate to see what's going on.


In master: https://github.com/mozilla-b2g/gaia/commit/6d3b81b3e5eeeb18b137657b145abcb3e66a49d9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8579144 [details] [review]
[gaia] yzen:bug-1139963 > mozilla-b2g:master

[Approval Request Comment] This PR fixes visibility issues around action menu
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: screen reader users would be able to access hidden content that is hidden underneath the action menu
[Testing completed]: on device, unit tests
[Risk to taking this patch] (and alternatives if risky): medium
[String changes made]: none
Attachment #8579144 - Flags: approval-gaia-v2.2?
Attachment #8579144 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(yzenevich)
Target Milestone: --- → 2.2 S8 (20mar)
Made a PR for v2.2
Flags: needinfo?(yzenevich) → needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.