[SMS] File name will run off the edge of the screen when saving a received picture with a long file-name.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: jmitchell, Assigned: pdahiya)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][polish][priority])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8573355 [details]
logcat_20150305_0947.txt

Description:
 When viewing pictures sent via SMS / MMS you have the option to save it locally. When you do so you receive a bottom banner that states the file has been saved. If the filename is very long then it will run off the right side of the screen.


Repro Steps:
1) Update a Flame to 20150305010212
2) From another device receive a MMS with a picture attached with a very long file name
3) Open the MMS
4) Tap on the picture
5) Tap on Save

Actual:
 File name runs off the right side of the screen

Expected:
 Better looking UX, perhaps some truncation with ... 

Environmental Variables:
Device: Flame Master
Build ID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency: 7/7
See attached: logcat, sceenshot
(Reporter)

Comment 1

4 years ago
Created attachment 8573356 [details]
2015-03-05-09-53-50.png
(Reporter)

Comment 2

4 years ago
This issue also occurs on Flame 2.2, 2.1 and 2.0

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150302000457
Gaia: 366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gecko: 1bd33f5447d2
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Looks like a Gallery issue.
Component: Gaia::SMS → Gaia::Gallery
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(npark)
It's not a regression, so I won't nominate it for blocking, but definitely would be nice if this gets fixed.
Flags: needinfo?(npark)
Hema, can we add this to the priority list as well?
Flags: needinfo?(hkoka)

Comment 7

4 years ago
Punam,

When you get a chance fix this.

Thanks
Hema
Flags: needinfo?(hkoka) → needinfo?(pdahiya)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][polish][priority]
(Assignee)

Comment 8

4 years ago
Assigning myself to investigate and fix.
(Assignee)

Updated

4 years ago
Flags: needinfo?(pdahiya)
(Assignee)

Updated

4 years ago
Assignee: nobody → pdahiya
Created attachment 8578835 [details] [review]
[gaia] punamdahiya:Bug1139997 > mozilla-b2g:master
(Assignee)

Comment 10

4 years ago
Comment on attachment 8578835 [details] [review]
[gaia] punamdahiya:Bug1139997 > mozilla-b2g:master

Hi Wilson
Please review attached CSS fix that break word to display in next line if the file name received is too long. Thanks!
Attachment #8578835 - Flags: review?(wilsonpage)
Attachment #8578835 - Flags: review?(wilsonpage) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/28927

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
Hmm, lots of tree closures and now TC problems. Let's manually land this one for now, sorry about the infra issues.

In master: https://github.com/mozilla-b2g/gaia/commit/4cd033e45a82cbdb41bf330c6d29a97470f8eeb8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Created attachment 8697490 [details]
Verified_2015-12-11-16-26-42.png

This bug has been verified as "pass" on latest build of Flame KK v2.5& master and Aries KK 2.5& master by the STR in Comment 0.

Results: 
The file name of the picture is displayed without truncation.

See attachment: Verified_2015-12-11-16-26-42.png

Reproduce rate: 0/10

Device: Flame v2.5_512mb ( Pass )
Build ID               20151211000407
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.231805
Firmware Date          Thu Dec 10 23:18:14 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame master_512mb ( Pass )
Build ID               20151210150222
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151210.183953
Firmware Date          Thu Dec 10 18:40:06 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5  ( Pass )
Build ID               20151211001044
Gaia Revision          2eb55a6193b711b4acb5944be3ba8fea138506c8
Gaia Date              2015-12-10 21:18:06
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/d0aa054f0eeae855ff0b4d7ef6c984ab96fd1944
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.232018
Firmware Date          Thu Dec 10 23:20:26 UTC 2015
Bootloader             s1

Device: Aries KK master  ( Pass )
Build ID               20151210120926
Gaia Revision          7e962276913bd4da7ce5fa7540767107ce322c78
Gaia Date              2015-12-09 21:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/412e4d7ce98ca4dbc37de133d0f26d7e1a59946f
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151210.112747
Firmware Date          Thu Dec 10 11:27:55 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.