If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disable SSL 3 in the default NSS configuration

RESOLVED FIXED in 3.19

Status

NSS
Libraries
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [postponed until April 2015])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
It's time.
(Reporter)

Comment 1

3 years ago
Created attachment 8573392 [details] [diff] [review]
bug1140029.patch

As we discussed on the call.
Attachment #8573392 - Flags: review?(kaie)
(Reporter)

Updated

3 years ago
Depends on: 1083900
(Reporter)

Comment 2

3 years ago
Oops, that doesn't depend on bug 1083900, let me fix that.
(Reporter)

Comment 3

3 years ago
Created attachment 8573395 [details] [diff] [review]
bug1140029.patch

Now it really does depend on bug 1083900.
Attachment #8573392 - Attachment is obsolete: true
Attachment #8573392 - Flags: review?(kaie)
Attachment #8573395 - Flags: review?(kaie)

Updated

3 years ago
Target Milestone: --- → 3.18.1

Updated

3 years ago
Whiteboard: [postponed until April 2015]

Comment 4

3 years ago
Comment on attachment 8573395 [details] [diff] [review]
bug1140029.patch

r=kaie

I'd like to delay checking this in until April 1st.
Attachment #8573395 - Flags: review?(kaie) → review+
(Reporter)

Comment 5

3 years ago
Maybe the 2nd.  We should disable TLS and re-enable SSLv2 on April 1st.
Duplicate of this bug: 1083762
(In reply to Martin Thomson [:mt] from comment #5)
> Maybe the 2nd.  We should disable TLS and re-enable SSLv2 on April 1st.

Don't forget to enable RC4 and give the highest priority. (I'm afraid many servers are always using this 1st April settings...)
(Reporter)

Comment 8

3 years ago
I realize that this is nearly two weeks late, but it's in now:

https://hg.mozilla.org/projects/nss/rev/37369a50eb75
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Target Milestone: 3.18.1 → 3.19
You need to log in before you can comment on or make changes to this bug.