Fix regressions caused by enabling desktop reader view toolbar button

RESOLVED FIXED in Firefox 39

Status

()

Toolkit
Reader Mode
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Margaret, Assigned: Margaret)

Tracking

({meta})

Trunk
mozilla39
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 fixed)

Details

(Assignee)

Description

3 years ago
Unfortunately, enabling the reader toolbar button caused regressions related to memory/CPU usage, including some pretty bad intermittent test failures, so I'm going to disable this again until we have these sorted out.

We can use this bug to track the issues we need to fix before we can re-enable this.
(Assignee)

Comment 1

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/2205ab3f21a6
https://hg.mozilla.org/mozilla-central/rev/2205ab3f21a6
Assignee: nobody → margaret.leibovic
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
If this is the tracking bug now for Reader, why is it marked 'FIXED' ?
(Assignee)

Comment 4

3 years ago
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #3)
> If this is the tracking bug now for Reader, why is it marked 'FIXED' ?

Sorry, this was a confusing use of bugzilla. I'll re-summarize and re-open to track what we need to do to re-enable this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Disable desktop reader view toolbar button again because of regressions → Fix regressions caused by enabling desktop reader view toolbar button
Whiteboard: [leave open]
Keywords: meta
(Assignee)

Comment 5

3 years ago
My patch for bug 1140172 should prevent us from running into bug 1139250 again, so let's try re-enabling this:
https://hg.mozilla.org/integration/fx-team/rev/c186a66948fb

I'm curious if the talos regressions will re-appear, and if they do, if they will have the same magnitude.
https://hg.mozilla.org/mozilla-central/rev/c186a66948fb
Depends on: 1141757
Depends on: 1142183
(Assignee)

Updated

3 years ago
Depends on: 1142374
Priority: -- → P2
(Assignee)

Comment 7

3 years ago
Closing this out, as all dependencies are fixed.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Whiteboard: [leave open]
You need to log in before you can comment on or make changes to this bug.