Firefox loads WOFF font from cache when cache explicitly disabled

RESOLVED DUPLICATE of bug 1030718

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1030718
3 years ago
3 years ago

People

(Reporter: John A. Bilicki III, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20150105205548

Steps to reproduce:

I disabled the cache via the Web Developer Toolbar by Chris Pederick. Both Firebug's Net tab and the native Firefox developer tools Network tab do not show the WOFF file being requested yet fonts are using the font while also simultaneously the font is not installed in the windows\fonts directory.

I believe the person who fixed the following older bug just forced font files to utterly ignore the cache flag/setting: https://bugzilla.mozilla.org/show_bug.cgi?id=654081


Actual results:

Font file was NOT loaded via network and instead loaded from cache.

Tested on Firefox 8 (ESR 31) as I am not on my primary production system and can't mess around fixing hyper-release Firefox every 42 days.


Expected results:

When cache is disabled the font should load from the network.

If the cache is enabled and the font has not previously been loaded then the font should load from the network.

If the cache is enabled and the font has been previously loaded then the font should load from the cache.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030718
You need to log in before you can comment on or make changes to this bug.