Intermittent test-windows.js.testTrackWindows | Test timed out (after: window was closed)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
11 months ago

People

(Reporter: RyanVM, Assigned: evold)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
13:56:52 INFO - TEST-INFO | executing 'jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows'
13:56:54 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | expecting activate 0
13:56:54 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | global activate 0
13:56:55 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | expecting deactivate 0
13:56:56 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | global deactivate 0
13:56:56 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | expecting activate 1
13:56:56 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | global activate 1
13:56:57 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | expecting deactivate 1
13:56:57 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | global deactivate 1
13:56:58 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | expecting activate 2
13:56:58 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | window was closed
13:57:07 INFO - 2015-03-05 13:57:07: stackwalker.cc:125: INFO: Couldn't load symbols for: /builds/slave/test/build/application/firefox/libxul.so|4884AA443A9DC4E358588A5411CE0D8C0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x6dbd38c0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xbfecd50c
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x23a
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xb712b508
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xbfecd4d8
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xb7136900
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x1f4
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xbfecd4d8
13:57:07 INFO - 2015-03-05 13:57:07: stackwalker.cc:125: INFO: Couldn't load symbols for: /builds/slave/test/build/application/firefox/libnspr4.so|12C123CC5F059186D2476C9A59ABEFAF0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x1f4
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x2
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xcec681da
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x196
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x6dbd38d4
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x0
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xb7136900
13:57:07 INFO - 2015-03-05 13:57:07: stackwalker.cc:125: INFO: Couldn't load symbols for: /lib/i386-linux-gnu/librt.so.1|54623F3F5813D2229B35185F6C7351D40
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xcec681da
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x196
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0x1
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xbfecd518
13:57:07 INFO - 2015-03-05 13:57:07: basic_code_modules.cc:88: INFO: No module at 0xb7136904
13:57:09 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | window was closed
13:57:11 WARNING - TEST-UNEXPECTED-FAIL | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | Test timed out (after: window was closed)
13:57:11 INFO - TEST-INFO | Traceback (most recent call last):
13:57:11 INFO - File "resource://gre/modules/commonjs/sdk/timers.js", line 40, in notify
13:57:11 INFO - callback.apply(null, args);
13:57:11 INFO - File "resource://gre/modules/commonjs/sdk/deprecated/unit-test.js", line 490, in tiredOfWaiting
13:57:11 INFO - self.console.testMessage(false, false, self.test.name,
13:57:11 INFO - File "resource://gre/modules/commonjs/sdk/test/harness.js", line 543, in testMessage
13:57:11 INFO - this.trace();
13:57:11 INFO - TEST-PASS | jetpack-package/addon-sdk/source/test/test-windows.js.testTrackWindows | window was closed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 1111478
Priority: -- → P1
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Assignee: nobody → evold
Duplicate of this bug: 1139176
Created attachment 8614714 [details] [review]
Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/2000
Attachment #8614714 - Flags: review?(jsantell)
Attachment #8614714 - Flags: review?(jsantell) → review+

Comment 42

3 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/94df212cedb9b528705c49b29ee5597f428131ca
Bug 1140127 Adding a couple more asserts to testTrackWindows

https://github.com/mozilla/addon-sdk/commit/ee44bb508a1b71a753c329794b4e18aab827511c
Merge pull request #2000 from erikvold/1140127v2

Bug 1140127 Adding a couple more asserts to testTrackWindows r=jsantell
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

2 years ago
Priority: P1 → --
https://bugzilla.mozilla.org/show_bug.cgi?id=1399562
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.