nokia.com - Doesn't display page on club nokia

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Daniele Dellafiore, Unassigned)

Tracking

Details

(Whiteboard: aok, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Go to www.club.nokia.com.
Then login, the page load for a while, then stop and leave the render incomplete.
Club nokia have a considerable number of users, I think :)

Comment 1

17 years ago
Reporter: Please remember to include build ID in bug-reports..
Also: Have you installed PSM?
(Reporter)

Comment 2

17 years ago
Bugzilla told me that he automatically recover my build id and other Mozilla
related infos.
So, build id is 2001112009, M0.9.6 for Windows.
Same problem with N6.2
(Reporter)

Comment 3

17 years ago
Ah, yes, I have installed PSM

Comment 4

17 years ago
reporter could you check with a more recent build ?
wfm with win2k and Mozilla 0.9.6

Please try it again with a new profile.
(run "mozilla -profilemanager")

Comment 6

17 years ago
teruko@netscape.com, can you help us decide what to do with this test case?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
oop, wrong bug. sorry. 
(Reporter)

Comment 8

17 years ago
tried with 2001121906 and nothing has changed, apparently.

Comment 9

17 years ago
->evangelism
Assignee: asa → doronr
Component: Browser-General → US General
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified
could you create a dummy account for us?

Updated

17 years ago
Whiteboard: aok
(Reporter)

Comment 11

17 years ago
Created attachment 63173 [details]
result page after login

attachment with the HTML i receive after login.
The page loads for a while, and at the end of transger show a blue page without

any text.

Comment 12

16 years ago
Can confirm problem using 1.0 RC1 on Windows 2000 (2002041711). The only pages
exhibbiting this problem appear to be the ones *after* you have logged in.

Everything within the problem page's BODY tags is enclosed within one or more
DIV tags similar to the following:


<div id="lyrContent" style="position: absolute; visibility: hidden; width: 620px;">


Obviously the "visibility: hidden" is why nothing is showing on screen. None of
the "pre-login" screens have these DIVs, and all of those appear to work OK.

None of the stylesheets attached to the page seem to modify the "visibility"
properties at all, but a couple of the external JavaScript files do seem to
adjust the properties of these DIVs. However the scripts appear to be using a
lot of IE specific code (document.all and so on) and the only client sniffing
seems to consist entirely of:


 function oL() { preparePage(); }
 onload= oL;
 var ns= (document.layers)?1:0;
 if (ns) {
   document.writeln('<img src="/content/europe/const_pics/1x1.gif" width="1"
height='+(document.lyrContent.document.height+document.lyrCopy.document.height)+'
border=0>');
 }


Which of course will have the wrong effect with Mozilla.

Suggest this is really an evangelism issue?

PS I don't think its going to be possible to set up a dummy login very easily,
as setting up a new account needs personal details that Nokia are validating
themselves (it asks for a mobile phone number, a Serial/IMEI number from a Nokia
mobile, as well as an email and postal address). But the page attached above
(attachment 63173 [details]) is the problem page as I'm seeing it.
When I tried to tell nokia about the problem the form wasn't working, so I
phoned the careline and told them that the site didn't work with 'any
Gecko-based browser, which includes Netscape 6 and Compuserve 7'

They have my email address if they need more details.
Looks like they were having trouble with NS4 too. With my understanding, they
were using IE-specific code (document.all) in a section that is only meant to be
run by netscape.

var ns= (document.layers)?1:0;
if (ns) {
   document.writeln('<img src="/content/europe/const_pics/1x1.gif" width="1"
height='+(document.lyrContent.document.height+document.lyrCopy.document.height)+'
border=0>');
}

It is commented out, so I guess they didn't get it to work. (funny that).

Putting the following code in the head with a suitable online handler, should be
a quick workaround, but for some reason doesn't work.

<script>
function showGecko() {
 if (navigator.userAgent.indexOf('Gecko') != -1) {
  alert('set to visible');
  document.getElementById('lyrContent').style.visibility = 'visible';
  document.getElementById('lyrBot').style.visibility = 'visible';
 }
 else { alert(navigator.userAgent); }
}
</script>

Updated

16 years ago
Summary: Doesn't display page on club nokia → nokia.com - Doesn't display page on club nokia

Comment 15

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 16

15 years ago
*** Bug 147563 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
WFM know, page seems redesigned
marking FIXED
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.