bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

LSAN-detected leak in optimization tracking

RESOLVED FIXED in Firefox 39

Status

()

Core
JavaScript Engine: JIT
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: shu, Unassigned)

Tracking

unspecified
mozilla39
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=5408307&repo=try

I think the problem is keeping non-JitAllocPolicy things (TypeSet::TypeList) inside JitAllocPolicy things. Their destructors are never called and they never get cleaned up.
(Reporter)

Comment 1

3 years ago
Created attachment 8573705 [details] [diff] [review]
Stop leaking TypeLists when tracking optimizations.
Attachment #8573705 - Flags: review?(kvijayan)

Updated

3 years ago
Attachment #8573705 - Flags: review?(kvijayan) → review+
https://hg.mozilla.org/mozilla-central/rev/0d5b57b0063b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.