Lots of debug spew from service worker bits

RESOLVED DUPLICATE of bug 1136950

Status

()

Core
DOM: Workers
RESOLVED DUPLICATE of bug 1136950
3 years ago
3 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

From a typical tinderbox log:

19:08:26     INFO -  [Parent 3208] WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file /builds/slave/try-lx-d-000000000000000000000/build/src/netwerk/protocol/http/HttpBaseChannel.cpp, line 1952
19:08:26     INFO -  [Parent 3208] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/slave/try-lx-d-000000000000000000000/build/src/dom/workers/ServiceWorkerManager.cpp, line 2370

repeated a bajillion times.

The problem is that ServiceWorkerManager::GetDocumentRegistration will return NS_ERROR_FAILURE if the hashtable lookup returns "no entry".  This (common case!) situation will lead to an immediate warning in ServiceWorkerManager::IsControlled (the second warning above) and then propagate up the tree to other consumers, leading to more warnings.
Flags: needinfo?(bkelly)

Comment 1

3 years ago
I agree, but I'm not that familiar with SWM.  Nikhil, can you look at silencing these?
Flags: needinfo?(bkelly) → needinfo?(nsm.nikhil)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136950
You need to log in before you can comment on or make changes to this bug.