Closed Bug 1140277 Opened 7 years ago Closed 4 years ago

test_dialer_clear_miss_call_notification.py failed because caller number is withheld

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: shinglyu, Unassigned)

References

Details

*** Description
test_dialer_clear_miss_call_notification.py failed because caller number is withheld

*** Steps to Reproduce
* Run gaia-ui-test functional/dialer/test_dialer_clear_miss_call_notification.py

*** Expected Results
The test passes

*** Actual Results
The incoming call number is "Withheld Number instead of the plivo phone number, causing the following error:

TEST-UNEXPECTED-FAIL | test_dialer_clear_miss_call_notification.py TestDialerClearMissCallNotification.test_dialer_clear_miss_call_notification | AssertionError: False is not true

Traceback (most recent call last):
  File "/home/slyu/.virtualenvs/gaiauitest/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/home/slyu/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_clear_miss_call_notification.py", line 75, in test_dialer_clear_miss_call_notification
    self.assertTrue(plivo_phone_number[1:] in notifications[0].content)


*** Other Notes
Not reproduced manually

*** Reproduction Frequency
4/4

*** Build
  Gaia-Rev        eb86137e247224e86d17ed1a0a133b2a318dce3c
  Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e9d29a3b94e5
  Build-ID        20150305162505
  Version         37.0
  Device-Name     flame
  FW-Release      4.4.2
  FW-Incremental  65
  FW-Date         Mon Dec 15 18:51:29 CST 2014
  Bootloader      L1TC000118D0
Probably due to the same reason as in bug 1140278.
See Also: → 1140278
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.