Closed Bug 1140278 Opened 7 years ago Closed 4 years ago

test_dialer_miss_call_from_known_contact_notification.py failed because caller number is withheld

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: shinglyu, Unassigned)

References

Details

Attachments

(1 file)

*** Description
test_dialer_miss_call_from_known_contact_notification.py failed because caller number is withheld

*** Steps to Reproduce
* Run gaia-ui-test functional/dialer/test_dialer_miss_call_from_known_contact_notification.py

*** Expected Results
The test passes

*** Actual Results
The incoming call number is "Withheld Number", so the missed call notification doesn't show the plivo number, causing the following error:

TEST-UNEXPECTED-FAIL | test_dialer_miss_call_from_known_contact_notification.py TestReceiveCallFromKnownContactNotification.test_dialer_miss_call_from_known_contact_notification | AssertionError: False is not true

Traceback (most recent call last):
  File "/home/slyu/.virtualenvs/gaiauitest/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
    testMethod()
  File "/home/slyu/workspace/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer_miss_call_from_known_contact_notification.py", line 64, in test_dialer_miss_call_from_known_contact_notification
    self.assertTrue(self.contact.givenName in lock_screen.notifications[0].content)

*** Other Notes
Not reproduced manually

*** Reproduction Frequency
2/2

*** Build
  Gaia-Rev        eb86137e247224e86d17ed1a0a133b2a318dce3c
  Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e9d29a3b94e5
  Build-ID        20150305162505
  Version         37.0
  Device-Name     flame
  FW-Release      4.4.2
  FW-Incremental  65
  FW-Date         Mon Dec 15 18:51:29 CST 2014
  Bootloader      L1TC000118D0
From the Plivo logs, I see that the American phone number calls some Taiwanese phone numbers. This might be an operator issue.

Shing, do you know how often it happens?
Flags: needinfo?(slyu)
See Also: → 1140277
(In reply to Johan Lorenzo [:jlorenzo] (QA) - On PTO, back on March 16th from comment #1)
> From the Plivo logs, I see that the American phone number calls some
> Taiwanese phone numbers. This might be an operator issue.
> 
> Shing, do you know how often it happens?

Roughly around 80% of the time.
Flags: needinfo?(slyu)
That's a really high frequency. This might be an operator issue. To make sure of it, can we get a logcat with RIL logs enabled[1], Shing?

[1] https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#RIL_Debugging
Flags: needinfo?(slyu)
OK. Let me try that.
Flags: needinfo?(slyu)
Attached file adb.log
This is the adb logcat output while running gaiatest/tests/functional/dialer/test_dialer_receive_all_with_contact_photo.py

3/5 times the number is withheld.
After taking a look, I don't see any differences between the calls logged by RILWorker. So it would not be an issue from the carrier standpoint like I suggested. Do you confirm all the calls received in attachment 8578467 [details] should display the number, Hsin-Yi?
Flags: needinfo?(htsai)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #6)
> After taking a look, I don't see any differences between the calls logged by
> RILWorker. So it would not be an issue from the carrier standpoint like I
> suggested. Do you confirm all the calls received in attachment 8578467 [details]
> [details] should display the number, Hsin-Yi?

According to the log, the number logged/received in gecko was empty (number:"") with the reason "unknown" (numberPresentation:2). In sum, in this case, it's expected to see "withheld" on gaia, i.e. it's expected to display no number.

== log snippet ==
I/Gecko   ( 1839): RIL Worker: Next parcel size unknown, going to sleep.
I/Gecko   ( 1839): -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":4,"callIndex":1,"toa":129,"isMpty":false,"isMT":true,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"","numberPresentation":2,"name":null,"namePresentation":2,"uusInfo":null,"isOutgoing":false,"isConference":false},"rilMessageClientId":0}
Flags: needinfo?(htsai)
b.t.w. Shing Lyu, were you doing these tests with the office landline phones? If so, I won't be surprised that we encounter this failure randomly and frequently because some extension in taipei office was set to hide the phone number intentionally. I'd suggest you test this with cellphones and make sure you set "CLIR" in settings app properly.
Flags: needinfo?(slyu)
@Hsin-Yi: The gaia-ui-test uses https://www.plivo.com/ to make automated calls. I believe their call center is located in the US or elsewhere, so I assume it is a operator problem. 

I guess someone has to contact Plivo customer service. Johan, do you have access to the Plivo account? Or do you know anyone who can do this? Thanks.
Flags: needinfo?(slyu) → needinfo?(jlorenzo)
Yes, I have access to the Plivo account. We only have one American number. I agree with the suspected operator issue.

We can create a line in Taiwan. However, this line would be able to place outbound calls only[1]. As far as I remember, the Gaia UI Tests only use Plivo to make outbound calls. So creating a Taiwanese line sounds okay to me.

[1] https://www.plivo.com/pricing/TW/
Flags: needinfo?(jlorenzo)
Sounds good! Do we have to modify any settings in gaia ui tests or will pilvo switch to Tawian line based on the callee number?
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.