[Search] Settings root page covers Search app when offline

VERIFIED DUPLICATE of bug 1137722

Status

defect
--
major
VERIFIED DUPLICATE of bug 1137722
4 years ago
4 years ago

People

(Reporter: hcheng, Assigned: benfrancis)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

* Description:
Network setting activity is not triggered at search app when offline. Besides, Settings root page covers Search app after incorrect Settings activity triggered.

* STR:
1. no network connection
2. launch search app and input something
3. tap "No internet connection" to launch network setting activity
4. click home button to Homescreen
5. tap rocketbar to relaunch search app

* Expected result
1. after step 3, it should launch correct network setting activity
2. after step 5, it should launch search app and search app should not be covered over by Settings root page.

* Actual result
1. after step 3, it launch Settings root page but not network settings
2. after step 5, Settings root page covers over search app.
You need to restart the phone, and then can launch search app correctly.

* Video link
https://www.youtube.com/watch?v=2Gj5h5VnCeM
* Env info:
Build ID               20150305162505
Gaia Revision          eb86137e247224e86d17ed1a0a133b2a318dce3c
Gaia Date              2015-03-05 16:51:07
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e9d29a3b94e5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150305.200709
Firmware Date          Thu Mar  5 20:07:21 EST 2015
Bootloader             L1TC000118D0
Severity: normal → major
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
Can you make the video public?
Flags: needinfo?(hcheng)
blocking-b2g: 2.2? → 2.2+
This is what you see after you tap the rocketbar to try to type something.
(In reply to Gregor Wagner [:gwagner] from comment #1)
> Can you make the video public?

sorry about that, it has been done.

(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #2)
> Created attachment 8574158 [details]
> 2015-03-06-21-35-05.png
> 
> This is what you see after you tap the rocketbar to try to type something.

I have opened a bug for this issue (Bug 1140315).
Flags: needinfo?(hcheng)
Assignee: nobody → bfrancis
Assignee

Comment 4

4 years ago
I've had a look at this. Firstly, I think the fact that the settings window remains on top of the search window is intended behaviour, it's a child window for an inline activity.

However, there appears to be a regression (I suspect in the search app) in handling the configure activity such that the root section of the settings app is not filtered and marked as a dialog. This means that no "Done" button is displayed to dismiss the window.

Can we please get a regression window to narrow down the cause?

Arthur, do you have any idea what may have broken this web activity?
Flags: needinfo?(arthur.chen)
Did a branch check per our normal procedures.  This issue occurs on the 3.0 and 2.2 builds but not 2.0 builds.  Finding the window now.  A prerequisite step is missing in the description which may help those working on fixing this issue.

Prerequisite:
1) Have the settings app open.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150311062433
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311073246
Gaia: 50e6d85c26beb25357fbd8cce8d85a17e18df9c0
Gecko: 432f2052890e
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20150311034134
Gaia: 091e6d614d1945c07b96d91e2c6c1d52b9b5776d
Gecko: fde5f8581e23
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ktucker)
QA Contact: jmercado
Flags: needinfo?(ktucker)
Bug 1126119 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211012654
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: 42d960d1f148
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150211022003
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: e60f5fee730f
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working gaia / First Broken gecko - 
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: e60f5fee730f

First Broken gaia / Last Working gecko - 
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: 42d960d1f148

Gecko Pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=42d960d1f148&tochange=e60f5fee730f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kan-Ru, can you take a look at this please? Looks like the work done on bug 1126119 might be the cause here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kchen)
I found that the system message is not sent to instance opened by the activity if there is already a settings app instance running. This might be a regression of bug 1126119 as comment 8 suggested.
Flags: needinfo?(arthur.chen)
Blocks: 1126119
I'm going to land bug 1137722, could you check if this is a duplicated bug?
Flags: needinfo?(kchen)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137722
NI myself for following verification.
Flags: needinfo?(hcheng)
After bug 1137722 is resolved, this issue does not occur again. Close this one.
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.