very slow loading of page with debugger open and ocasional script error

RESOLVED INCOMPLETE

Status

DevTools
Debugger
RESOLVED INCOMPLETE
3 years ago
5 days ago

People

(Reporter: mowa1000, Unassigned, NeedInfo)

Tracking

36 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

load a page containing Ext js 3.4 JavaScript library with browser debugger open (checked with firebug and native debugger). Can be reproduced at http://docs-origin.sencha.com/extjs/3.4.0/


Actual results:

page loads very slow (15-20 sec) with few second of total browser unresponsiveness, and every now and then there is also a script error (ext-base.js)


Expected results:

the page should load relatively quick (2-3 sec) without any script errors. I have been working with ext js and firefox since ff 3.0 and there was never such an issue

Comment 1

3 years ago
Hello Reporter, Thanks for reporting this issue. I tried accessing the URL that you specified (http://docs-origin.sencha.com/extjs/3.4.0/) but got "503 - Service Unavailable" response code from the server. Can you please upgrade your firefox to the latest version and let us know if you still see the issue. If yes then please provide us a working URL for benchmark and further troubleshooting.

Please note that I am currently using below Firefox version for reproducing this issue.  

Name 	Firefox
Version 	43.0.2
Build ID 	20151221130713
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Component: Untriaged → Developer Tools: Debugger
Flags: needinfo?(mowa1000)

Comment 2

2 years ago
Resolved-Incomplete due to time since last communication/update by reporter.
Please feel free to reopen if the error occurs in a current Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE

Updated

5 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.