[OMTC] Black rectangle appears during animation on blocked GPU such as on VMware Player

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

33 Branch
x86_64
Windows 8.1
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36 affected, firefox37 affected, firefox38 affected, firefox39 affected, firefox40 affected, firefox41 affected, firefox42 affected, firefox43 unaffected, firefox44 unaffected, firefox-esr31 unaffected, firefox-esr38 affected)

Details

(Whiteboard: [gfx-noted][fixed in 43])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1138934 +++

Build Identifier:
https://hg.mozilla.org/integration/mozilla-inbound/rev/713a86aa0c37
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150305173855

Bug 1138934 does not fix the graphic glitch.

I can still see the graphic glitch on the the build (m-i cset 713a86aa0c37)

Black rectangle appears during animation.

This problem happens on Windows BLOCKED GPU.
Or set the following prefs
user_pref("gfx.direct2d.disabled", true);
user_pref("layers.acceleration.force-enabled", true);
user_pref("layers.offmainthreadcomposition.enabled", true);

Steps to reproduce:
1. Maximized
2. Open http://www.strobilanthes.com/
3. Observe animation

Actual Results:
Black rectangle appears during animation


Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b37955bdf1b6&tochange=99690880e8f5

Regressed by: 99690880e8f5	Bas Schouten — Bug 1035227: Upload partial surfaces when an upload region is specified. r=nical


Graphics
--------

Adapter Description: VMware SVGA 3D
Adapter Drivers: vm3dum64 vm3dum vm3dgl64 vm3dgl
Adapter RAM: 128
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.3.9600.17415)
Driver Date: 10-28-2013
Driver Version: 7.14.1.5026
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 WARP (OMTC)
Subsys ID: 040515ad
Vendor ID: 0x15ad
WebGL Renderer: Google Inc. -- ANGLE (VMware SVGA 3D Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Are you absolutely certain? I've checked three times and I can most certainly reproduce this -without- the patch but I cannot reproduce it -with- the patch in a local build.
Flags: needinfo?(alice0775)
(Reporter)

Comment 2

3 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #1)
> Are you absolutely certain? I've checked three times and I can most
> certainly reproduce this -without- the patch but I cannot reproduce it
> -with- the patch in a local build.

Yes. I can reproduce the problem.
A. Windows7 SP1 64bit
B. Windows8.1 or Windows10TP on VMware Player guest(hosted by Windows7 SP1 64bit)

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1425643716/firefox-39.0a1.en-US.win32.zip (the build include the patch of Bug 1138934)
   
https://hg.mozilla.org/mozilla-central/rev/7d85ac833cff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150306040836

https://hg.mozilla.org/mozilla-central/rev/7d85ac833cff
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150306040836

https://hg.mozilla.org/mozilla-central/rev/7d85ac833cff
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150306040836
Flags: needinfo?(alice0775)
I can also try once we have a nightly with this patch in it.
(In reply to Milan Sreckovic [:milan] from comment #3)
> I can also try once we have a nightly with this patch in it.

Yeah, I'd be really surprised if you can reproduce it, but if you can I have absolutely no idea. I most certainly can't.
Don't be surprised yet :), as I can't reproduce it on 2015-03-09 nightly.
(Reporter)

Comment 6

3 years ago
Created attachment 8574877 [details]
reduced testcase bug.html

Reproduced on
https://hg.mozilla.org/mozilla-central/rev/eab4a81e4457
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150309030224

Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
Device ID: 0x6779
DirectWrite Enabled: false (6.2.9200.16571)
Driver Date: 11-20-2014
Driver Version: 14.501.1003.0
GPU #2 Active: false
GPU Accelerated Windows: 2/2 Direct3D 11 (OMTC)
Subsys ID: 23111787
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

And also on
https://hg.mozilla.org/mozilla-central/rev/43fb1f92e8d4
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 ID:20150307030233

Graphics
--------

Adapter Description: VMware SVGA 3D
Adapter Drivers: vm3dum64 vm3dum
Adapter RAM: 832
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (10.0.9926.6)
Driver Date: 7-29-2014
Driver Version: 8.14.1.51
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 WARP (OMTC)
Subsys ID: 040515ad
Vendor ID: 0x15ad
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Whiteboard: [gfx-noted]
I can also reproduce this on Windows 7 x64 (actual physical machine), using both http://www.strobilanthes.com/ and the attached testcase (I usually have to wait for the 2nd or 3rd animation to see the black rectangles), with:
- Firefox 37 Beta 4 - BuildID: 20150309191715
- latest Firefox 38 Aurora - BuildID: 20150310004228
- latest Firefox 39 Nightly - BuildID: 20150309030224

I can see the black rectangles (especially with the attached testcase) only if I set the preferences that Alice specified in comment 0:
"gfx.direct2d.disabled"=true
"layers.acceleration.force-enabled"=true
"layers.offmainthreadcomposition.enabled"=true

Graphics info with these settings:
---------------------------------

Adapter Description: NVIDIA GeForce GT 610
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x104a
DirectWrite Enabled: false (6.2.9200.16571)
Driver Date: 2-5-2015
Driver Version: 9.18.13.4752
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 104a10b0
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

If I spoof the graphics (with a clean profile) to get the same OS, Device ID, Vendor ID, and Driver Version as Alice, then I cannot reproduce the problem on Firefox 36.

Graphics info with spoofing of graphics:
---------------------------------------

Adapter Description: NVIDIA GeForce GT 610
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.2.9200.16571)
Driver Date: 2-5-2015
Driver Version: 7.14.1.5026
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics card because of unresolved driver issues.
Subsys ID: 104a10b0
Vendor ID: 0x15ad
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #7)
> I can also reproduce this on Windows 7 x64 (actual physical machine), using
> both http://www.strobilanthes.com/ and the attached testcase (I usually have
> to wait for the 2nd or 3rd animation to see the black rectangles), with:
> - Firefox 37 Beta 4 - BuildID: 20150309191715
> - latest Firefox 38 Aurora - BuildID: 20150310004228
> - latest Firefox 39 Nightly - BuildID: 20150309030224
> 
> I can see the black rectangles (especially with the attached testcase) only
> if I set the preferences that Alice specified in comment 0:
> "gfx.direct2d.disabled"=true
> "layers.acceleration.force-enabled"=true
> "layers.offmainthreadcomposition.enabled"=true
> 
> Graphics info with these settings:
> ---------------------------------
> 
> Adapter Description: NVIDIA GeForce GT 610
> Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
> Adapter RAM: 2048
> Device ID: 0x104a
> DirectWrite Enabled: false (6.2.9200.16571)
> Driver Date: 2-5-2015
> Driver Version: 9.18.13.4752
> GPU #2 Active: false
> GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
> Subsys ID: 104a10b0
> Vendor ID: 0x10de
> WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11
> vs_5_0 ps_5_0)
> windowLayerManagerRemote: true
> AzureCanvasBackend: skia
> AzureContentBackend: cairo
> AzureFallbackCanvasBackend: cairo
> AzureSkiaAccelerated: 0
> 
> If I spoof the graphics (with a clean profile) to get the same OS, Device
> ID, Vendor ID, and Driver Version as Alice, then I cannot reproduce the
> problem on Firefox 36.
> 
> Graphics info with spoofing of graphics:
> ---------------------------------------
> 
> Adapter Description: NVIDIA GeForce GT 610
> Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
> Adapter RAM: 2048
> Device ID: 0x0405
> Direct2D Enabled: Blocked for your graphics card because of unresolved
> driver issues.
> DirectWrite Enabled: false (6.2.9200.16571)
> Driver Date: 2-5-2015
> Driver Version: 7.14.1.5026
> GPU #2 Active: false
> GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics card
> because of unresolved driver issues.
> Subsys ID: 104a10b0
> Vendor ID: 0x15ad
> WebGL Renderer: Blocked for your graphics card because of unresolved driver
> issues.
> windowLayerManagerRemote: true
> AzureCanvasBackend: skia
> AzureContentBackend: cairo
> AzureFallbackCanvasBackend: cairo
> AzureSkiaAccelerated: 0

Hola! This is a whole different configuration, you somehow ended up on OMTC basic. I wonder if those pref combinations somehow trigger that. For the record, this is -not- a configuration our users can receive on Win7+.
(Reporter)

Updated

3 years ago
status-firefox40: --- → affected
(Reporter)

Comment 9

3 years ago
I can still reproduce the problem on Nightly42.0a1 on Windows10 VM woth disabled e10s and disabled HWA.

https://hg.mozilla.org/mozilla-central/rev/f34a7120f46b
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150709030206



Graphics
--------

Adapter Description: VMware SVGA 3D
Adapter Drivers: vm3dum64 vm3dum
Adapter RAM: 1024
Asynchronous Pan/Zoom: none
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (10.0.10166.0)
Driver Date: 7-29-2014
Driver Version: 8.14.1.51
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 WARP (OMTC)
Subsys ID: 040515ad
Supports Hardware H264 Decoding: false
Vendor ID: 0x15ad
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox-esr38: ? → affected
(Reporter)

Updated

3 years ago
Summary: [OMTC] Black rectangle appears during animation on blocked GPU → [OMTC] Black rectangle appears during animation on blocked GPU such as on VMware Player
The thread is somewhat confusing.  Can we arrive at a situation with a particular combination of the hardware and drivers that gets us to the system we are trying to simulate with those preferences?  Because it changes the priority of this bug.
(Reporter)

Comment 11

3 years ago
Reproduced with
・Blocked GPU
・Disabled e10s

I think this this is common for old GPU.
(Reporter)

Comment 12

3 years ago
I can reproduce on Firefix42.0b3
However, I cannot reproduce on Nightly44.0a1 and Aurora43.0a2 anymore
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → unaffected
status-firefox44: --- → unaffected
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Whiteboard: [gfx-noted] → [gfx-noted][fixed in 43]
You need to log in before you can comment on or make changes to this bug.