Closed Bug 1140424 Opened 9 years ago Closed 3 months ago

WebGL causes extremely low FPS and screen flickers on machines with Radeon 3000 and 5450

Categories

(Core :: Graphics, defect)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox36 --- wontfix
firefox37 - affected
firefox38 - affected
firefox39 - affected

People

(Reporter: avaida, Unassigned)

Details

(Whiteboard: gfx-noted)

Reproducible on:
Beta 37.0b3 (20150305191659), Release 36.0.1 (20150305021524), Nightly 39.0a1 (2015-03-06), Aurora 38.0a2 (2015-03-06)

Affected platforms:
Ubuntu 12.04, Ubuntu 14.04 with AMD Radeon 3000 graphics card only

Steps to reproduce: 
1. Launch Firefox with a clean profile.
2. Access a website with WebGL content - e.g. http://webglsamples.org/aquarium/aquarium.html.
3. Check the FPS count.

Expected result:
WebGL content is displayed and works properly, without any glitches, flickers and at a reasonable FPS count.

Actual result:
The screen flickers and the FPS count shows 2 to 10 frames per second, at best.

Notes:
- Ubuntu machines with Radeon HD 6450 and Intel HD 2500 are not affected, so this seems to be an issue isolated to Radeon 3000.
- Other examples:
 * http://racer.nomo.hu/ - about 2-4 frames/sec
 * http://www.3dsitelinks.com/do.php?url=95 - about 3 frames/sec
- This might be a regression, but it needs further investigation. I'll follow up with a regression range as soon as possible.
Note that this was reproduced with Firefox 32.0.3 as well, so it doesn't seem to be a recent regression.
[Tracking Requested - why for this release]: Though this is not a recent regression, it renders WebGL content almost useless in some cases.
Andrei, what does the graphics section of about:support look like for the failing configuration?
I'm not tracking as we've already shipped at least 4 releases with this issue and haven't heard any feedback. We definitely want to fix this perf issue but I'll let Milan triage this as per his normal process.
(In reply to Milan Sreckovic [:milan] from comment #3)
> Andrei, what does the graphics section of about:support look like for the
> failing configuration?

Here's the graphics section from an affected Ubuntu 14.04 x86 machine with AMD Radeon 3000:

Adapter Description		X.Org -- Gallium 0.4 on AMD RS780
Device ID			Gallium 0.4 on AMD RS780
Driver Version			3.0 Mesa 10.1.3
GPU Accelerated 		Windows	0/1 Basic
Vendor ID			X.Org
WebGL Renderer			X.Org -- Gallium 0.4 on AMD RS780
windowLayerManagerRemote	false
AzureCanvasBackend		cairo
AzureContentBackend		cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated		0
This is reproducible also for:

FF 37.0b5
Build Id:	20150312193711
OS: Ubuntu 14.04 x86
Graphics
Adapter Description	ATI Technologies Inc. -- AMD Radeon HD 5450
Device ID	AMD Radeon HD 5450
Driver Version	4.3.12798 Compatibility Profile Context 13.35.1005
GPU Accelerated Windows	0/1 Basic
Vendor ID	ATI Technologies Inc.
WebGL Renderer	ATI Technologies Inc. -- AMD Radeon HD 5450
windowLayerManagerRemote	false
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
Summary: WebGL causes extremely low FPS and screen flickers on machines with Radeon 3000 → WebGL causes extremely low FPS and screen flickers on machines with Radeon 3000 and 5450
Severity: normal → S3

Since we cant reproduce this issue in our older Versions of Ubuntu 20.04 and Ubuntu 22 we can close this as "Works for me" for now, but we can reopen in case this issue starts to reoccur. Doubt it though, thous old GPUs are a bit outdated.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.