If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

battery level indicators (statusbar, settings) doesn't update while device is in sleep mode/screen turned off

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

B2G 3.0 20150305015452 on Geeksphone Keon

The battery level indicators (in the status bar and in Settings) dsn't update while the device has the screen turned off (only in sleep mode?)

Steps to reproduce:
1. Check the charging level in Settings (shown for the Battery submenu).
2. Turn the screen of device off.
3. Wait for hours or a night.
4. Turn screen on and check charging level in statusbar and Settings.
Actual result:
Battery is still at same level like in 1.
5. In Display, disable the automatic turning off of the screen.
6. Wait some time (10 minutes?).
7. Check battery level.
Actual result: Battery level has fallen some percents, more than expect for the short time.

This can hurt you if you check the battery level e.g. in the morning...
With Settings you mean in the settings app?
Flags: needinfo?(archaeopteryx)
Yes, in the Settings app.
Flags: needinfo?(archaeopteryx)
Is this a regression?
Keywords: qawanted
Was a regression, can't reproduce anymore (neither on Keon nor on Flame on master).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.