If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmark manager not opening new window as expected (smoketest b.23)

VERIFIED INVALID

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: tracy, Assigned: Paul Chen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
seen on commercial trunk builds:

windows 2001-12-07-06-trunk
linux 2001-12-07-06-trunk
mac 2001-12-07-04-trunk

-open bookmark manager
-double click a bookmark to open the page

expected results:  a new browser window opens with the page
tested results: the page loads in the current browser window

noticed bug 104914 saying this is how it should work...??
ccing blake who's been doing bookmarks stuff lately...

Comment 2

16 years ago
This behavior has been changed. What should be the default action, open or open 
in new window?  (Both context menu items are available.)  When we decide, both 
this and history need to be changed.

Comment 3

16 years ago
techinically this is the valid bug and 104914 is a request for enhancement, but
that doesn't really matter because there is no damn spec. People will complain
either way we default this behavior so the best we can do is be consistent.

Clicking bookmarks in every other context will load in your current window (of
course every other time is a single-click and this would be a double, but i
think that's too subtle a diff to matter) so we might as well do that. Also, if
we offer open in New Window in the context menu it more closely mimics a
navigator window context menu(aiding consistency). Plus there is the 4xp issue.
I can't think of any strong arguments for opening a new window (although it is
my personal pref).

So, how about we close one of these bugs. Leave the behavior as is, make sure
the context menu contains the other option and make history do the same thing.

Comment 4

16 years ago
sounds good to me.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
verified...

I'll change the smoketests page to reflect the new expected behavior (page loads 
in current browser)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.