"Failed to open a chat window" while NOT in private browsing

RESOLVED DUPLICATE of bug 1150052

Status

Hello (Loop)
Client
P2
normal
Rank:
24
RESOLVED DUPLICATE of bug 1150052
3 years ago
3 years ago

People

(Reporter: abr, Assigned: standard8)

Tracking

unspecified
x86
Mac OS X
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [quality][watch])

(Reporter)

Description

3 years ago
I recently tried to have a discussion with one of the TB guys using Hello, but he was unable to get the conversation panel to open at all.

I had him double-check that he was not in private browsing mode, so this isn't Bug 1118518 (although it may be related). This is highly reproducible on his browser, which he claims is largely in a stock configuration (no add-ons, etc). He first encountered the issue on 35, but upgraded to 36 and found it still broken.

Logs leading up to the failure look like:

"hawkRequest: /rooms" 1 MozLoopService.jsm:629
"promiseRegisteredWithServers: registration already completed or in progress:" 1 MozLoopService.jsm:375
"hawkRequestInternal: " 1 "/rooms" "POST" MozLoopService.jsm:541
"[Dispatcher] Dispatching action" Object { nameTemplate: "Conversation {{conversationLabel}}", roomOwner: "Guest", name: "createRoom" } dispatcher.js:71:8
"notifyStatusChanged with reason:" "room-add" MozLoopService.jsm:244
"[Dispatcher] Dispatching action" Object { roomList: Array[2], name: "updateRoomList" } dispatcher.js:71:8
"[Dispatcher] Dispatching action" Object { roomToken: "<removed>", name: "createdRoom" } dispatcher.js:71:8
"[Dispatcher] Dispatching action" Object { roomToken: "<removed>", name: "openRoom" } dispatcher.js:71:8
Failed to open a chat window - no host window could be found. Chat.jsm:113:0

Although we should definitely get to the bottom of what is triggering this error, we may also (as mitigation) want to look at how difficult it would be to open a "popped out" chat panel instead of emitting an error under these circumstances. That approach would also assist greatly in the user experience for Bug 1118518.
(Reporter)

Comment 1

3 years ago
Whoever picks up this bug should contact me; I can put you in touch with the person who has the browser in question.
Tentatively taking, this is in a class of a few bugs along this line that I'd like to nail down if possible - Adam please put me in touch.
Assignee: nobody → standard8
Iteration: --- → 39.2 - 23 Mar
Duplicate of this bug: 1118518

Updated

3 years ago
Rank: 24
Priority: -- → P2
Whiteboard: [quality][watch]

Updated

3 years ago
Flags: firefox-backlog+
(Reporter)

Comment 4

3 years ago
I've managed to reproduce this, or at least some variation on it. Right now, I have a window where I can open the chat window for *some* conversations, but not for others. The failures result in the following three error messages:

---------------------------------------------------------------------------
MozLoopAPI.jsm:113

"Failed to clone value:" TypeError: cb is null
Stack trace:
openChat@chrome://browser/content/socialchat.xml:541:1
Chat.open@resource://app/modules/Chat.jsm:119:19
MozLoopServiceInternal.openChatWindow@resource:///modules/loop/MozLoopService.jsm:900:5
this.MozLoopService.openChatWindow@resource:///modules/loop/MozLoopService.jsm:1236:12
LoopRoomsInternal.open@resource://app/modules/loop/LoopRooms.jsm:331:5
this.LoopRooms.open@resource://app/modules/loop/LoopRooms.jsm:541:12
injectObjectAPI/</injectedAPI[func]@resource://app/modules/loop/MozLoopAPI.jsm:157:54
loop.store.RoomStore<.openRoom@chrome://browser/content/loop/shared/js/roomStore.js:417:7
loop.Dispatcher</Dispatcher.prototype._dispatchNextAction/<@chrome://browser/content/loop/shared/js/dispatcher.js:76:11
loop.Dispatcher</Dispatcher.prototype._dispatchNextAction@chrome://browser/content/loop/shared/js/dispatcher.js:74:7
loop.Dispatcher</Dispatcher.prototype.dispatch@chrome://browser/content/loop/shared/js/dispatcher.js:48:7
loop.panel</RoomEntry<.handleClickEntry@chrome://browser/content/loop/js/panel.js:665:1
a@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23169
[92]</R.executeDispatch@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:20972
i@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23101
s@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23222
[19]</c@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:19991
[123]</n@chrome://browser/content/loop/shared/libs/react-0.12.2.js:16:1309
[19]</p.processEventQueue@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:20898
n@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14066
[60]</o.handleTopLevel@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14183
o@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14642
[104]</r.perform@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:27988
[54]</p.batchedUpdates@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:7657
o@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:11152
[61]</m.dispatchEvent@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:15701


---------------------------------------------------------------------------
dispatcher.js:71:8
"[Dispatcher] Dispatching action" Object { roomToken: "<removed>", name: "openRoom" }

---------------------------------------------------------------------------
dispatcher.js:78:10
"[Dispatcher] Dispatching action caused an exception: " Error: Encountered unsupported value type writing stack-scoped structured clone
Stack trace:
cloneValueInto@resource://app/modules/loop/MozLoopAPI.jsm:111:13
injectObjectAPI/</injectedAPI[func]@resource://app/modules/loop/MozLoopAPI.jsm:159:18
loop.store.RoomStore<.openRoom@chrome://browser/content/loop/shared/js/roomStore.js:417:7
loop.Dispatcher</Dispatcher.prototype._dispatchNextAction/<@chrome://browser/content/loop/shared/js/dispatcher.js:76:11
loop.Dispatcher</Dispatcher.prototype._dispatchNextAction@chrome://browser/content/loop/shared/js/dispatcher.js:74:7
loop.Dispatcher</Dispatcher.prototype.dispatch@chrome://browser/content/loop/shared/js/dispatcher.js:48:7
loop.panel</RoomEntry<.handleClickEntry@chrome://browser/content/loop/js/panel.js:665:1
a@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23169
[92]</R.executeDispatch@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:20972
i@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23101
s@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:23222
[19]</c@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:19991
[123]</n@chrome://browser/content/loop/shared/libs/react-0.12.2.js:16:1309
[19]</p.processEventQueue@chrome://browser/content/loop/shared/libs/react-0.12.2.js:12:20898
n@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14066
[60]</o.handleTopLevel@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14183
o@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:14642
[104]</r.perform@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:27988
[54]</p.batchedUpdates@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:7657
o@chrome://browser/content/loop/shared/libs/react-0.12.2.js:15:11152
[61]</m.dispatchEvent@chrome://browser/content/loop/shared/libs/react-0.12.2.js:14:15701

Comment 5

3 years ago
Not sure if this is useful, but I'd like to add that this also happens if Firefox is set to "Never remember history" in Edit -> Preferences -> Privacy -> History.
Iteration: 39.2 - 23 Mar → 40.1 - 13 Apr
Iteration: 40.1 - 13 Apr → 40.2 - 27 Apr
Iteration: 40.2 - 27 Apr → 40.3 - 11 May
My best guess is that this is related to bug 1150052 that we just fixed, especially with the logs from comment 4. Therefore I'm going to mark as a duplicate of that.

(In reply to Adrian Iain Lam from comment #5)
> Not sure if this is useful, but I'd like to add that this also happens if
> Firefox is set to "Never remember history" in Edit -> Preferences -> Privacy
> -> History.

This is a separate issue with private browser - Hello is now disabled completely in private browsing mode, for which bug 1005019 will look at re-enabling it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150052
You need to log in before you can comment on or make changes to this bug.