Expose HTML Headings for a Quick Table of Contents for All Users

RESOLVED DUPLICATE of bug 670928

Status

()

Toolkit
Reader Mode
--
enhancement
RESOLVED DUPLICATE of bug 670928
3 years ago
a year ago

People

(Reporter: Mike Gifford, Unassigned)

Tracking

35 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222008

Steps to reproduce:

The heading structure of a page should be exposed for all users. Sighted users can benefit from seeing the heading structure of a complex document. Providing a quick way to see the headings in the main content and skip directly to the heading of intrest would be of benefit to many people.


Actual results:

At the moment either a screen reader or plugin would be required to see the headings. 


Expected results:

Exposing headers to content editors by default will make content creators be more aware of the table of contents feature that is essentially built into HTML. Like what is available in Microsoft Word, people benefit from scanning headers of a document.

Comment 1

3 years ago
+1
This would be incredibly useful

Also for the Anchor tags used as section names (after # in URL) as defined by id="foo". I often want to provide a URL to a section but have to open the source or developer tools and look for the anchor.

Updated

3 years ago
Severity: normal → enhancement
QA Whiteboard: [bugday-20150309]
Component: Untriaged → General
OS: Linux → All

Comment 2

3 years ago
Blair, does the planned reader mode feature offer something in that direction?
Flags: needinfo?(bmcbride)
(Reporter)

Updated

3 years ago
Summary: Expose HTML Headers for a quick Table of Contents for all Users → Expose HTML Headings for a Quick Table of Contents for All Users

Comment 3

3 years ago
And, just to be clear - these should be navigable via the keyboard!  We need this for aria-landmarks, too (I will make sure that is filed in a separate issue).

Comment 4

3 years ago
(In reply to Becky Gibson from comment #3)
> And, just to be clear - these should be navigable via the keyboard!  We need
> this for aria-landmarks, too (I will make sure that is filed in a separate
> issue).
The aria-landmarks issue is here: https://bugzilla.mozilla.org/show_bug.cgi?id=670928
(In reply to Marco Zehe (:MarcoZ) from comment #2)
> Blair, does the planned reader mode feature offer something in that
> direction?

No idea :) I'm mostly concentrated on the Reading List; Margaret is the person to ask about Reader Mode (aka Reader View).
Flags: needinfo?(bmcbride) → needinfo?(margaret.leibovic)

Comment 6

3 years ago
Currently we're focused on just making reader view display correct content (e.g. no missing paragraphs/headers), but this sounds like an interesting idea for the future.
Component: General → Reader Mode
Flags: needinfo?(margaret.leibovic)
Product: Firefox → Toolkit

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

2 years ago
Please see bug 670928 comment 59. If the proposal there is accepted, then this bug can become a dup of that one.

Comment 8

a year ago
This wasn't originally filed as a reader mode issue, and I don't think reader mode would/will adequately address the need here. Reader mode only works on 'articles' (which yes, is a little fuzzy, but clearly doesn't include all pages, which addressing this request *should* do).

I'm going to mark this as a dupe of bug 670928. We should deal with headings/landmarks navigation in a unified manner and it can be done in that bug or some of the related ones (like bug 321632).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670928
You need to log in before you can comment on or make changes to this bug.