[Contacts][Label] A very long custom label will continue off the edge of the screen in edit view

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
P2
normal
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: DerekH, Assigned: jgw9617, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(3 attachments)

Description:
When adding a very long custom tag to the email label section of a contact, the label will continue off the screen in the contacts edit mode view


Repro Steps:
1) Update a Flame to 20150306010207
2) Open Contacts app> and tap on "+" to create a new contact
3) Scroll down to email section> Tap on the label ("personal" by default)
4) Tap in the custom space and type a very long string of text
5) Tap done


Actual:
Email label continues off the edge of the page


Expected:
Email label is truncated to fid the label box

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150306010207
Gaia: 7a91c16bfa348be8b25e09719178efa051512988
Gecko: 0189941a3fd5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/FCt8gaje5Fg
Created attachment 8574161 [details]
logcat_contacts_email_label.txt
This issue DOES occur on Flame 2.2, 2.1, 2.0 and base v18D-1


Email label continues off the edge of the page


Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Device: Flame 2.0
Build ID: 20150225000239
Gaia: 366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gecko: 611444d72a92
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Device: Flame v18D-1 (319mb)(Kitkat)
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 1125783
Mistakenly duped this issue. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 8583753 [details]
V2.2.png

Not an everyday case, but bad UI. Suggest to backlog.
Flags: needinfo?(francisco)
Moving the NI to Wesley. I don't see tracking-b2g? anymore. How can we nominate this issue for backlog, Wesley?
Flags: needinfo?(francisco) → needinfo?(whuang)
[Tracking Requested - why for this release]:

We no longer need to nominate for backlogs. 
You should be able to set tracking-b2g:backlog[1] directly.
This is to encourage all the team members to groom the bucket by using the flag more frequently.

The change was made two weeks ago in Bug 1141452.


[1] https://wiki.mozilla.org/B2G/Triage#Project_Flags
tracking-b2g: --- → backlog
Flags: needinfo?(whuang)
Priority: -- → P2
(Assignee)

Comment 8

3 years ago
I can take this bug if nobody else wants it? I already have a fix, expect a pull request soon!
Created attachment 8696413 [details] [review]
[gaia] jgw96:email-longtag-fix > mozilla-b2g:master
(Assignee)

Comment 10

3 years ago
See pull request above! Thanks
Assignee: nobody → jgw9617
Thanks :jgw9617 !

For review, you can add the flag 'review' to myself, I will do this time and start the review process \o/
Comment on attachment 8696413 [details] [review]
[gaia] jgw96:email-longtag-fix > mozilla-b2g:master

To be more precise:

You setup the flag 'review' to value '?', and in the input you put my bugzilla email: francisco@jordano.es
Attachment #8696413 - Flags: review?(francisco)
Comment on attachment 8696413 [details] [review]
[gaia] jgw96:email-longtag-fix > mozilla-b2g:master

I just finished the review, left some feedback in github:

Tested on the phone and works perfectly, but unfortunately that's a shared file, which means there are more applications using it. So if we add this patch we will be modifying almost all apps using the same style.

We will need to overwrite this values in the specific css files for the contacts app, you can try here:
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/style/app.css

Now I remove the review flag, whenever you change your PR, please setup the review flag again to me :)

Thanks!!
Flags: needinfo?(jgw9617)
Attachment #8696413 - Flags: review?(francisco)

Comment 14

3 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.