[Contacts] The star indicating a favorite contact overlaps long contact names in the header of the contact details page

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: julienw)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Posted image ImAStar.png
Description:
When you select as contact as a favorite it will add a star to the header of the contact detail page. If the contact has a long name, the star will overlap part of the name.

Repro Steps:
1) Update a Flame to 20150306010207
2) Launch Contact App
3) Create a contact with a long name and set it as a favorite
4) Select that contact to view the contact details page

Actual:
Name in header is overlapped by the star

Expected:
No text overlapping

Environmental Variables:
Device: Flame Master
Build ID: 20150306010207
Gaia: 7a91c16bfa348be8b25e09719178efa051512988
Gecko: 0189941a3fd5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Repro frequency: 7/7
See attached:screenshot
(Reporter)

Comment 1

4 years ago
This issue also occurs on 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150306002519
Gaia: eb86137e247224e86d17ed1a0a133b2a318dce3c
Gecko: a04034e239fb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------------------------------------------------------------

This issue does NOT reproduce on 2.1

Actual Results - the contact name will use both truncation and a smaller font to avoid overlapping text with the star

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150302001220
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 9bf4c663241f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
This is a regression and looks bad so nominating 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150210011855
Gaia: e846bc37ade8eaad82a00ffda6eb34906dbcc07f
Gecko: 20ae4196ad67
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150210020821
Gaia: 8cade57c020f952bfe561c76f4afbcc51029e25a
Gecko: 876dde5c2924
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES NOT reproduce 
Gaia: e846bc37ade8eaad82a00ffda6eb34906dbcc07f
Gecko: 876dde5c2924

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 8cade57c020f952bfe561c76f4afbcc51029e25a
Gecko: 20ae4196ad67

https://github.com/mozilla-b2g/gaia/compare/e846bc37ade8eaad82a00ffda6eb34906dbcc07f...8cade57c020f952bfe561c76f4afbcc51029e25a

possibly caused by bug 1129850
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Julien, can you take a look at this please? Looks like this could be caused by bug 1129850 but there are multiple issues listed in the commits.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(felash)
(Assignee)

Comment 5

4 years ago
I'm leaving for holidays for 1 week -- either this waits one more week, either you can ask somebody else. (but I think Wilson is away for 1 more week as well).

The big failing commit is more likely bug 1112131; the other ones were small changes.
Moving to the correct component
Component: Gaia::Contacts → Gaia::Components
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
See Also: → 1134009
(Assignee)

Comment 7

4 years ago
I tried various things but nothing works properly.

* the star itself is part of the <h1>. I tried putting it in a separate <div> but gaia-header does not import the div into the shadow dom.
* we can't set a padding on <h1> to keep the background because it gets overwritten by gaia-header.

Wilson, what do you think?

(I also admit I don't really understand the fix from bug 1134009)
Flags: needinfo?(felash) → needinfo?(wilsonpage)
(In reply to Julien Wajsberg [:julienw] (PTO March 7th -> 15th) from comment #7)
> I tried various things but nothing works properly.
> 
> * the star itself is part of the <h1>. I tried putting it in a separate
> <div> but gaia-header does not import the div into the shadow dom.
> * we can't set a padding on <h1> to keep the background because it gets
> overwritten by gaia-header.
> 
> Wilson, what do you think?
> 
> (I also admit I don't really understand the fix from bug 1134009)

I suggest we 'suck in' other elements other than 'a,button,h1' and then alter the `getButtonsAfterTitle()` to `getElementsAfterTitle()`, then we can shove the star in a <div> after the <h1>.
Flags: needinfo?(wilsonpage)
(Assignee)

Comment 9

4 years ago
I think we can do this. I hope we won't run into much more issues :/
(Assignee)

Updated

4 years ago
Assignee: nobody → felash
(Assignee)

Comment 10

4 years ago
Attachment #8579420 - Flags: review?(wilsonpage)
(Assignee)

Updated

4 years ago
Attachment #8579435 - Flags: review?(francisco)
Comment on attachment 8579420 [details] [review]
gaia-header github PR

LGTM :) Just a nit about using proper gaia-icon in the `index.html` demo.
Attachment #8579420 - Flags: review?(wilsonpage) → review+
Comment on attachment 8579435 [details] [review]
[gaia] julienw:1140613-star-contacts > mozilla-b2g:master

Just tried the patch and looking pretty good!
Attachment #8579435 - Flags: review?(francisco) → review+
(Assignee)

Comment 14

4 years ago
NI me to land this monday. Also I'd like to land this with bug 1137097 to make things easier.
Flags: needinfo?(felash)
(Assignee)

Comment 15

4 years ago
gaia-header master: 5604cebb4632bd97c966f2d7c3a8add4a120433b
Flags: needinfo?(felash)
(Assignee)

Comment 16

4 years ago
gaia-header v0.8.0 stamp: 64da8f8103b21960230b2d6e3f2412e8441d052f

Updated

4 years ago
Blocks: 1141832
(Assignee)

Comment 19

4 years ago
(uplift request for the gaia-header upgrade has been asked in bug 1137097)
(Assignee)

Comment 20

4 years ago
Comment on attachment 8579435 [details] [review]
[gaia] julienw:1140613-star-contacts > mozilla-b2g:master

Rebased PR with latest master, will wait for a Gaia-try run and will check on device before merging.
(Assignee)

Comment 21

4 years ago
Hey Francisco,

I have issues with my computers currently, which prevents me from testing on a device. Can you please test the latest PR on your device and merge if this looks OK?

Thanks a lot !
Flags: needinfo?(francisco)
(Assignee)

Comment 22

4 years ago
My adb is working again, so I could try on the device and land:

gaia master: 9bb138f591a06e7b844f9a94fc3ba7b0ad98a0d5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 23

4 years ago
Comment on attachment 8579435 [details] [review]
[gaia] julienw:1140613-star-contacts > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1112131
[User impact] if declined: the "favorite" star can be on top of the contact name if the contact name is long.
[Testing completed]: yes, manually
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8579435 - Flags: approval-gaia-v2.2?
(Assignee)

Updated

4 years ago
Flags: needinfo?(francisco)
Attachment #8579435 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reverting for being believed to have caused the failures on Gij3 earlier today as seen in the below logs. I believe this was not captured in the gaia-try run due to the false positive gaia-try results.

Logs: https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/rwKRzRkmSZOUMBsT9iOARA/0/public/logs/live_backing.log

Revert commit: https://github.com/mozilla-b2g/gaia/commit/6b20a88725b70d13f7fbfb27274cf6114f151ed5
Status: RESOLVED → REOPENED
Flags: needinfo?(felash)
Resolution: FIXED → ---
Depends on: 1147553
Attachment #8579435 - Flags: approval-gaia-v2.2+
(Assignee)

Comment 25

4 years ago
Ah yeah, looks likely... Will fix tomorrow and reland :/
(Assignee)

Updated

4 years ago
Attachment #8579435 - Attachment is obsolete: true
Flags: needinfo?(felash)
(Assignee)

Comment 27

4 years ago
Comment on attachment 8583733 [details] [review]
[gaia] julienw:1140613-star-contacts > mozilla-b2g:master

fixed the intgration test.

carrying over r=francisco
Attachment #8583733 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 30

4 years ago
master: b77ce6b7ccb9d5193a3f98c3381f9e2ccbf7a36f
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 31

4 years ago
Comment on attachment 8583733 [details] [review]
[gaia] julienw:1140613-star-contacts > mozilla-b2g:master

[Approval Request Comment]
See comment 23
Attachment #8583733 - Flags: approval-gaia-v2.2?
Attachment #8583733 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been successfully verified on Flame2.2, Flame3.0
Reproducing rate: 0/5
Device: Flame 2.2
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.