cannot dismiss or snooze reminders

RESOLVED DUPLICATE of bug 356002

Status

Calendar
Alarms
RESOLVED DUPLICATE of bug 356002
3 years ago
3 years ago

People

(Reporter: BW~Merlin, Unassigned)

Tracking

Lightning 3.3

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

I get reminders for calendar events correctly but I am unable to dismiss or snooze the reminder.  When clicking on the snooze or dismiss button nothing happens.  If I close the reminder window down I get the same reminder a short while later.  My calendar is my hotmail/outlook.com calendar and shared into lightning using the ICS share link.  I am running Windows 8.1 update Enterprise 64bit and Thunderbird 31.5.0


Actual results:

Timestamp: 7/03/2015 20:58:04
Error: : <error>'<error>' when calling method: [calICalendar::modifyItem]
Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/<username>/AppData/Roaming/Thunderbird/Profiles/j2m5dbun.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calAlarmService.js
Line: 199


Expected results:

I should be able to dismiss or snooze my event reminder.

Comment 1

3 years ago
Do you have write access to the calendar, i.e. can you create/edit events in this calendar in Lightning?
Flags: needinfo?(bwmerlin)
(Reporter)

Comment 2

3 years ago
No I cannot edit or create an event in lightning, when I untick "read only" in the calendar properties I can momentarily snooze or dismiss a reminder but then an error window pops up saying "An error occurred when writing to the calendar hotmail calendar" and if I click on details it says error code "modification_failed".

Checking the link permissions of the calendar online the share permission is set so that "Anyone with these links can view event details on this calendar" and I do not seem to be able to share the calendar (at least to another programme) to give them edit rights.
Flags: needinfo?(bwmerlin)

Comment 3

3 years ago
Thank you for your response. Currently you need to have write access to the calendar to modify the reminders in the calendar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356002
You need to log in before you can comment on or make changes to this bug.