bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

SPS data gets out of sync with framerate and events

RESOLVED DUPLICATE of bug 1145187

Status

DevTools
Performance Tools (Profiler/Timeline)
RESOLVED DUPLICATE of bug 1145187
3 years ago
a month ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Might be related to the SPS ring buffer being too small. Either way, it will fill up, while the events and FPS won't. We don't have any way of dealing with this, AFAICT, and just assume that the buffer never fills up. This is pretty common as it fills up after like 10 seconds under normal usage (even less on 64bit, or with deep stacks).

I hear we are making the ring buffer bigger, but ideally it would either be dynamically grow-able or we would display to the user how much buffer space they have left and auto stop profiling when it is 100% full (like chrome does). Perhaps even user configurable?

That said, even when I don't think the buffer is full, we have syncing issues where I have to widen selection to get the SPS data associated with a specific framerate drop. Something weird going on here.
Can you post an example where the sync issues are obvious, while the profiler's circular buffer wasn't filled yet?
https://people.mozilla.org/~dcamp2/Sekrit/

With this asm code, on 64bits, the buffer gets filled in 3 seconds or so. When an enemy enters the screen, fps drops due to a gl link function, and the fps graph doesn't seem to line up with that function (looks like a few more rAF cycles occur within the fps drop, which doesn't make sense
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145187

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.