[3.0][nightly 20150308010227][Flame]FxA login failed error when opening Marketplace

RESOLVED WONTFIX

Status

Firefox OS
FxA
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Mike Jones, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 unaffected, b2g-master affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

open marketplace


Actual results:

Marketplace opens with "FxA login failed. a server error was encountered" error at bottom of screen.


Expected results:

Marketplace should open and sign in as normal with no errors.
QAwanted to see if this reproduces.
Keywords: qawanted
Able to reproduce on Flame 3.0

STR:
1) Navigate to Settings>Firefox Account and sign into valid account
2) Tap home button and open Marketplace
3) Tap gear icon in marketplace
4) Long press home button and open settings from card view
5) In settings app sign out of Firefox account
6) Long press home button and open marketplace from card view
7) Sign into Firefox account from marketplace
(May need to repeat steps 4-7 until issue occurs)

Actual results:
After finishing sign in process in Marketplace, a banner notification appears at bottom of screen with message as described in comment 0"

Repro rate 2/3

Device: Flame 3.0
Build ID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Unable to reproduce issue on Flame 2.2

When signing in to FxA through marketplace user is shown a banner notification at bottom of screen saying "signed in"

Repro rate: 0/9

Device: Flame 2.2
Build ID: 20150409002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Ever confirmed: true
Flags: needinfo?(ktucker)
Keywords: qawanted
I cant seem to repro this. I am on the 3.0, the banner I get across the bottom is signed in.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 40.0a1 (3.0)
Firmware Version: v18d_nightly_v2
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
This issue is not 100% and only seems to happen with specific steps so not nominating to block on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 5

3 years ago
At one time I had this big occur 100% of the time. With more recent nightly builds the error has not been occurring. Could this have been fixed unknowingly or can it still be reproduced?
Mike, I was able to get it on a recent 3.0, but not 100%, see comment 2
[Tracking Requested - why for this release]:

FMD issues are set to backlog since currently there is no dev resource to fix them.
tracking-b2g: --- → backlog

Comment 8

3 years ago
I am getting this error since a few days on my Flame. Do you need any extra logs?

Comment 9

3 years ago
I get this on my Flame with the latest OTA as well!

build:20151023030241 
commit 410e91dd

Comment 10

3 years ago
Usually you reproduce it by using your phone for some hours. It doesn't happen instantly you start the phone, more like after 8-10 hours, or the next day.

Comment 11

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.