If a page suggests MANY engines to add, "Search" opens a drop down menu longer than screen, and the UI stays too long for other sites. (does not scale, breaks)

RESOLVED DUPLICATE of bug 1113747

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1113747
3 years ago
3 years ago

People

(Reporter: ale, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

57.71 KB, image/png
Details
(Reporter)

Description

3 years ago
Created attachment 8574420 [details]
a4.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

- Go to e.g. http://de.pons.com and type something in the search box. You'll see a long list with several suggested search engines.
- After that, go to another website page (e.g. startpage.com) and try typing in the search box. Do you see a very long (and empty, this time) drop down menu? This makes no sense to me. Right? And this behaviour can be solved only restarting FF.


Actual results:

"Search" open a drop down menu so long that it occupies the entire height of the screen. This happens if I open the search while I am in a website that gives many possible search entries (e.g de.pons.com). After that, this long drop down menu always occurs, even if I'm on other website.


Expected results:

If no suggestions are available, no empty list should be displayed.

Comment 1

3 years ago
Reproduced with 2015-03-10-03-02-35-mozilla-central-firefox-39.0a1.ru.linux-x86_64.
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
Summary: "Search" open a drop down menu too long → If a page suggests MANY engines to add, "Search" opens a drop down menu longer than screen, and the UI stays too long for other sites. (does not scale, breaks)
Duplicate of this bug: 1138058

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113747
You need to log in before you can comment on or make changes to this bug.