[Messages] Bottom few pixels of Arabic characters cut off

RESOLVED DUPLICATE of bug 1150449

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1150449
3 years ago
2 years ago

People

(Reporter: steveck, Assigned: steveck)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-papercuts])

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
In https://github.com/mozilla-b2g/gaia/pull/28444#issuecomment-77583214, we found some Arabic characters will be cut because of inappropriate ratio of font-size/line height. Maybe it's time to revisit this issue in message app.
(Assignee)

Comment 1

3 years ago
WIP: https://github.com/steveck-chung/gaia/commit/e2e19b1aff0ec80645a777bcd1ff63d7a0a8ec7e

Since bug 1138350 will fix thread list RTL ellipsis display issue first, this patch will apply thread list fixing based on bug 1138350.
Whiteboard: [sms-papercutß]
Whiteboard: [sms-papercutß] → [sms-papercuts]
(Assignee)

Comment 2

3 years ago
Created attachment 8586707 [details]
text layout

Hi Fang, in order to display the Arabic text correctly, I adjust the contact name and number line-height to avoide certain char been cut(mostly because of this char "ي"). As you can see it will take much more space than orignal layout and the operator title might be very close to bottom line. Can you accept this text layout? Please note that I didn't left any space for padding/margin so there's not much room that we can reduce the space properly.
Attachment #8586707 - Flags: ui-review?(fshih)

Comment 3

3 years ago
Comment on attachment 8586707 [details]
text layout

Hi Steve, 
Thanks for the adjustment. I think the spacing looks fine between contact name and number in Arabic text. But I'm just a bit worry the bottom line may look way to close the text, especially in English text, while the spacing looks huge between name and number, but not much space left for the bottom part. Is there anything we can do about it by adding more space for bottom line? Thanks
Attachment #8586707 - Flags: ui-review?(fshih) → ui-review-
(Assignee)

Comment 4

3 years ago
Created attachment 8587148 [details]
text_layout_ver2

I tried negtive margin to reduce the space between the text, it seems still safe from the text truncate, but now quite sure if it's fine for all the cases.
Attachment #8587148 - Flags: ui-review?(fshih)
Depends on: 1150394

Comment 5

3 years ago
Comment on attachment 8587148 [details]
text_layout_ver2

It looks good! Thank a lot!
Attachment #8587148 - Flags: ui-review?(fshih) → ui-review+
No longer depends on: 1150394
(Assignee)

Comment 6

3 years ago
Per bug 1133137 comment 15, some fonts is missing in pvt and I can not reproduce this issue after using v18D base image. Close this one since bug 1152420 will keep tracking the missing fonts in pvt build.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1150449
You need to log in before you can comment on or make changes to this bug.