Closed Bug 1141055 Opened 7 years ago Closed 7 years ago

In-content prefs content pane starts with default font <menulist> controlling the wrong pref

Categories

(Firefox :: Preferences, defect, P1)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 39
Iteration:
39.2 - 23 Mar
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed

People

(Reporter: Kwan, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR (assuming desktop EN locale with default prefs):

1) Open in-content prefs
2) Navigate to content pane
3) default font: displays "Arial/Helvetica/sans-serif" (Win/OSX/Linux), controlling font.name.sans-serif.x-western

Should be "Times New Roman/Times/serif", controlling font.name.serif.x-western, since font.default.x-western is "serif" on desktop.

Old windowed prefs displays the correct value.

flipping the font.language.group to something else then back to x-western is enough to make the right value appear, as is flipping font.default.x-western.  Seems like _rebuildFonts() is not getting called a time when it should.
Looks like I broke this in bug 1012223
Blocks: 1012223
Keywords: regression
Priority: -- → P1
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #8578331 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/f981a0bd0e1c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
Hi Gijs, can you provide a point value.
Iteration: --- → 39.2 - 23 Mar
Flags: qe-verify?
Flags: needinfo?(gijskruitbosch+bugs)
Flags: firefox-backlog+
Points: --- → 3
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8578331 [details] [diff] [review]
fix in-content 'Content' pane preference initialization so rebuildFonts *actually* doesn't break,

Approval Request Comment
[Feature/regressing bug #]: bug 1012223
[User impact if declined]: Serious issue with not showing the right font preferences
[Describe test coverage new/current, TreeHerder]: this patch adds a test!
[Risks and why]: low, specific to the issue at hand
[String/UUID change made/needed]: nope
Attachment #8578331 - Flags: approval-mozilla-aurora?
Flags: qe-verify?
Flags: qe-verify-
Flags: in-testsuite+
Attachment #8578331 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.