crash in imgRequest::RemoveProxy(imgRequestProxy*, tag_nsresult)

RESOLVED FIXED

Status

()

Core
ImageLib
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-d942177e-05d7-492f-9683-c3f692150309.
=============================================================

Top frames:
0 	xul.dll 	imgRequest::RemoveProxy(imgRequestProxy*, tag_nsresult) 	image/src/imgRequest.cpp
1 	xul.dll 	imgRequestProxy::imgCancelRunnable::Run() 	image/src/imgRequestProxy.h
2 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
3 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
4 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
5 	xul.dll 	nsThreadManager::GetMainThread(nsIThread**) 	xpcom/threads/nsThreadManager.cpp
6 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
7 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
8 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
9 	xul.dll 	XREMain::XRE_main(int, char** const, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp

This is rising in 36.0.1, now at #20 with .5% of all crashes. Looks like all those are EXCEPTION_ACCESS_VIOLATION_READ at address 0x18.
(Click on the Crash Signature field to get more reports and stats for this signature.)
Seth, does this ring any bell?
looks like a dupe of bug 1116325 and bug 750629, or closely related at least.
Flags: needinfo?(seth)
See Also: → bug 1116325, bug 750629
Whiteboard: [gfx-noted]
This should be fixed by the patches hanging off of bug 1137002. All of those patches have landed, so even though I haven't resolved the metabug yet, I think we can resolve this unless someone hits it again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1137002
Flags: needinfo?(seth)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.