If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

/system/b2g/components/libxpcomsample.so" not found

RESOLVED DUPLICATE of bug 1089710

Status

Firefox OS
Runtime
RESOLVED DUPLICATE of bug 1089710
3 years ago
3 years ago

People

(Reporter: nhirata, Assigned: haydenh, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

IF you boot up b2g, you get: 
I/(Preallocated app)( 2361): Failed to load native module at path '/system/b2g/components/libxpcomsample.so': (80004005) dlopen failed: library "/system/b2g/components/libxpcomsample.so" not found

in the logcat.
Yep, it's harmless by I agree we should fix that. Good first bug that I'm happy to mentor.
Mentor: fabrice@mozilla.com
Component: GonkIntegration → Runtime
Whiteboard: [good first bug]
(Assignee)

Comment 2

3 years ago
I will take it as my first bug :)
I found libxpcomsample.so in some places, I could either include it in system/b2g/components folder or not to open that library. Do you have any suggestion?
Assignee: nobody → hahuang
We don't want to ship that and should not try to load it.
(Assignee)

Comment 4

3 years ago
log is gone after B2G_SDK is upgrade and set 30.0a1 in Bug#1089710
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089710
You need to log in before you can comment on or make changes to this bug.