Closed Bug 1141349 Opened 5 years ago Closed 5 years ago

Disable MSE for Mac for Firefox 37

Categories

(Core :: Audio/Video, defect, P1)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla37
Tracking Status
firefox36 --- unaffected
firefox37 + fixed
firefox38 --- unaffected
firefox39 --- unaffected

People

(Reporter: rillian, Assigned: maja_zf)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We're not confident with the state of Youtube interactions on Mac with MSE enabled. We should disable it once Youtube confirm they've flipped their side.
Assignee: nobody → giles
Attachment #8574941 - Flags: review?(ajones)
[Tracking Requested - why for this release]:
Chris, can you let us know when Youtube has updated and it's safe to land this? Target dates are Thursday and Monday morning.
Flags: needinfo?(cpeterson)
(In reply to Ralph Giles (:rillian) from comment #0)
> We're not confident with the state of Youtube interactions on Mac with MSE
> enabled.

Which bug(s) are you tracking for the mac?
Blocks: 1133633
Attachment #8574941 - Flags: review?(ajones) → review+
Comment on attachment 8574941 [details] [diff] [review]
Disable MSE on Mac for Firefox 37

Requesting approval for 37 beta. Again, this shouldn't land until we've confirmed YouTube has changed their behaviour to suit.

Approval Request Comment
[Feature/regressing bug #]: MSE
[User impact if declined]: Worse experience playing YouTube video.
[Describe test coverage new/current, TreeHerder]: N/A.
[Risks and why]: This is a pref flip, restoring us to the behaviour in 36 without the MSE feature. Video will be taking a different codepath. We'll have to keep in eye on bug 1131832.
[String/UUID change made/needed]: None.
Attachment #8574941 - Flags: approval-mozilla-beta?
(In reply to Jet Villegas (:jet) from comment #4)

> Which bug(s) are you tracking for the mac?

The main issue was bug 1133633 (performance issues on some systems) and concern about the uplift risk of patches currently landing on m-c to address resource contention through the 'dormant decoder' handling. There's no specific tracking bug for the mac dormant issue, but see bugs 1128381, 1128380, 1139779, and deps.
I'm holding Beta approval until Ralph confirms that YouTube is ready for the change.
YouTube says they will try to switch Mac back to Flash video on Thursday March 12, but we should verify the site has switched before pushing a beta with MSE disabled.
Flags: needinfo?(cpeterson)
I'm still seeing the html player this morning on a test Mac with 37b4 and flash installed.
Given comment 9, we're going to wait to take this fix in Beta 6.
Same today. I'm on PTO next week. Maja, could you check this Monday morning to see if we can land this in time for beta 6?

Just see if youtube defaults to flash instead of html on a Mac with flash installed for Firefox 37 the way it does for Firefox 36. (Check the right-click menu, for example.)
Flags: needinfo?(mjzffr)
Assignee: giles → mjzffr
I still see HTML5 video on YouTube this (Monday) morning.
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #12)
> I still see HTML5 video on YouTube this (Monday) morning.

Same here: I'm still seeing HTML5 video on 37_0b5 on Mac, using a temporary profile; Flash is installed.
Flags: needinfo?(mjzffr)
I'm now once again seeing Flash content on YouTube in 37 Beta 5 on OS X. Looks like the latest push has defaulted back to Flash.
Comment on attachment 8574941 [details] [diff] [review]
Disable MSE on Mac for Firefox 37

Now that YouTube is serving Flash content to Firefox on OS X again, let's disable MSE on OS X in Firefox 37. Beta+
Attachment #8574941 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.