OnHistoryPurge() PR_FALSE notification allows history purge

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: depman1, Assigned: radha)

Tracking

Trunk
mozilla0.9.8
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
reproduced in 12/3/01 mozilla debug build.
1. In CBrowserImpl::OnHistoryPurge (BrowserImplHistoryLstnr.cpp), set notification:
*notify = PR_FALSE.
2. cd /mozilla/embedding/qa/testembed
3. nmake -f makefile.win
4. cd ../../../dist/WIN_32D.OBJ/bin
5. testembed
6. Turn on history listener from Test menu.
7. Enter a couple of urls
8. Select "Purge History" test. (menu: Interfaces > nsISHistory > Purge History)
9. OnHistoryPurge() listener method is called. Press OK in msg box.
10. Now run through session history entry tests (Interfaces > nsISHistory >
nsIHistoryEntry > Run All Tests).

Result: indices and urls appear.
Expected: nothing should appear. session history should be purged.
(Reporter)

Comment 1

17 years ago
changed qa contact to depstein
QA Contact: mdunn → depstein
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
I worked with david on this and it is really not a bug. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
crossed them wires!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.