[Camera] Pulling down the notifications tray while searching in camera causes search results to remain on screen

RESOLVED DUPLICATE of bug 1132262

Status

RESOLVED DUPLICATE of bug 1132262
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: kgrandon)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(5 attachments)

Description:
If the user pulls down the status bar in camera, types in a search term and then quickly pulls down the notification tray, the search results will remain on the camera viewfinder as well as the homescreen. 

Repro Steps:
1) Update a Flame to 20150309010232
2) Open the camera app.
3) Pull down from the top of the viewfinder with your finger.
4) Type in a search term such as "pizza" into the Rocketbar.
5) Quickly pull down the notification bar while the search results are populating the screen.
6) Repeat steps 4 and 5 several times until encountering the issue.

Actual:
Search results remain on the camera viewfinder as well as the homescreen.

Expected:
Search results do not remain on the camera viewfinder or the homescreen once the Rocketabar has been closed.

Environmental Variables:
Device: Flame 2.2(Full Flash)(KK)(319mb)
BuildID: 20150309002506
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 91b7aa6a3243
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/10 attempts 50%
See attached: video, logcat
Adding qawanted for branch checks.
Keywords: qawanted
Whiteboard: [3.0-Daily-Testing]
Created attachment 8574989 [details]
SearchResultsonViewfinderlog.txt
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
I can repro this bug on latest Flame v2.1&3.0 and v2.1S,but can't repro on Flame v2.0.

Repro STR:
1.Open Camera app.
2.Pull down from the top of the viewfinder,and tap on Rocketbar.
3.Input some words into the Rocketbar,such as "pizza" or "goo".
4.Quickly slide down and slide up the notification bar while the search results are populating the screen.
5.Repeat step 2 & step 3 & step 4 several times.
**Search results remain on the camera viewfinder,and user can click on the search results into the corresponding URL.   --KO

Note:On Flame v2.0,there is no Rocketbar on the notifications bar in Camera screen.

Flame 2.0 build:
Build ID               20150309160225
Gaia Revision          8463d1c9142f32c8ea175048dac52e41620443ce
Gaia Date              2015-03-05 16:28:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c50c19e92162
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.192718
Firmware Date          Mon Mar  9 19:27:29 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1 build:
Build ID               20150309161206
Gaia Revision          a227b67d9ae647cc949ec1ef48ced00c80240025
Gaia Date              2015-03-09 15:56:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/a61c9c3dfba7
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.200323
Firmware Date          Mon Mar  9 20:03:34 EDT 2015
Bootloader             L1TC000118D0

2.1S 512mb:
Build ID               20150309161206
Gaia Revision          485b69e877429b85d08129ddd1cc2c22fd4806ce
Gaia Date              2015-03-09 03:47:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/fc6db70a7ea2
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

2.1S 256mb:
Build ID               20150309161206
Gaia Revision          485b69e877429b85d08129ddd1cc2c22fd4806ce
Gaia Date              2015-03-09 03:47:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/fc6db70a7ea2
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.194645
Firmware Date          Mon Mar  9 19:46:57 EDT 2015

Flame 3.0 build:
Build ID               20150309160227
Gaia Revision          4ef1fa9b2870499fc9c77cac4a15f62e12a3ad2c
Gaia Date              2015-03-09 02:53:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23f1f0369df5
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.192301
Firmware Date          Mon Mar  9 19:23:12 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
status-b2g-master: --- → affected
Keywords: qawanted
Created attachment 8575112 [details]
search results.png

Rate:5/10
Attchments:verify_v3.0.MP4 ,search results.png and logcat_v3.0_0607.txt
Created attachment 8575113 [details]
logcat_v3.0_0607.txt
Ni'ing HEma to triage this. I am surprised we did not see this earlier or in 2.1.
Flags: needinfo?(hkoka)

Comment 8

4 years ago
Not camera related. The Search results are not being cleared even after moving to homescreen too. Perhaps someone from Systems/Window Management should look into this first to see whats going on. 

NI'ing Alive and Gregor to see if they are right ones to look into this. If not, please forward to the right folks. 

Thanks
Hema
Flags: needinfo?(hkoka)
Flags: needinfo?(anygregor)
Flags: needinfo?(alive)

Updated

4 years ago
Component: Gaia::Camera → Gaia::System
(Assignee)

Comment 9

4 years ago
Adding qawanted to this for a restest - we've recently landed bug 1132262 which I think should fix this as well. Can we have a retest of master after the next nightly build? (It's not yet on 2.2)
status-b2g-master: affected → ?
Depends on: 1132262
Keywords: qawanted
(Assignee)

Comment 10

4 years ago
This could possibly be a dupe of bug 1132262.
Kevin will take a look.
Assignee: nobody → kgrandon
Flags: needinfo?(anygregor)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Clear ni since Kevin is on it.
Flags: needinfo?(alive)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
(In reply to Kevin Grandon :kgrandon from comment #10)
> This could possibly be a dupe of bug 1132262.

Alright duping for now, but QA has to verify this particular case once we land 1132262

Updated

4 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1132262
Per Comment 9 and Comment 13,I can't repro this bug on latest Flame v3.0,then remove "qawanted".

Rate:0/10
Attachment:verify_retest_v3.0.mp4.

Flame 3.0 build (unaffected):
Build ID               20150312160232
Gaia Revision          eabe35cf054d47087b37c1ca7db8143717fbd7f3
Gaia Date              2015-03-12 18:01:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/42afc7ef5ccb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150312.194521
Firmware Date          Thu Mar 12 19:45:32 EDT 2015
Bootloader             L1TC000118D0
status-b2g-master: ? → unaffected
Keywords: qawanted
Created attachment 8577050 [details]
verify_retest_v3.0.mp4
You need to log in before you can comment on or make changes to this bug.