Closed Bug 1141447 Opened 5 years ago Closed 5 years ago

Fix test_cost_control_data_alert_mobile.py

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cynthiatang, Assigned: martijn.martijn)

References

()

Details

Attachments

(4 files)

Attached file Smoketest report
[Description]
test_cost_control_data_alert_mobile.py errors. Because the title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project"

[Steps to Reproduce]
Run test_cost_control_data_alert_mobile.py 

[Expected Results]
Marionette can get the right title after browsing 'http://www.mozilla.org/'.

[Actual Results]
The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project"

*** Reproduction Frequency
100% 5/5

Traceback (most recent call last):
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot1_Kitkat/B2G_Gaia_2dot1/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g34_v2_1-0.2-py2.7.egg/marionette/marionette_test.py", line 174, in run
    testMethod()
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot1_Kitkat/B2G_Gaia_2dot1/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_data_alert_mobile.py", line 49, in test_cost_control_data_alert_mobile
    self.wait_for_condition(lambda m: "Home of the Mozilla Project" in m.title)
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot1_Kitkat/B2G_Gaia_2dot1/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 937, in wait_for_condition
    Wait(self.marionette, timeout).until(method, message=message)
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot1_Kitkat/B2G_Gaia_2dot1/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g34_v2_1-0.2-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.1 seconds

[Build info]
Gaia-Rev        ea97a87048a4c1e2a479bbea1d75e0a182b2c4c9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0443f2e951dc
Build-ID        20150309001219
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150309.040008
FW-Date         Mon Mar  9 04:00:19 EDT 2015
Bootloader      L1TC100118D0

[Attachments]
Smoketest report
Summary: The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project" → [Cost Control] The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project"
Summary: [Cost Control] The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project" → The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project"
Assignee: nobody → martijn.martijn
Comment on attachment 8576709 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py > mozilla-b2g:master

Instead of using a website we don't control (at least, not QA), use an image bigger than 0.1MB that is on the mozqa.com site.
Attachment #8576709 - Flags: review?(npark)
Attachment #8576709 - Flags: review?(gmealer)
Summary: The title is "We’re building a better Internet — Mozilla", not "Home of the Mozilla Project" → Fix test_cost_control_data_alert_mobile.py
Comment on attachment 8576709 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py > mozilla-b2g:master

I'm guessing webqa team maintains it but they don't change it too often?
Attachment #8576709 - Flags: review?(npark) → review+
They are aware that they shouldn't change things there.
Comment on attachment 8576817 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py_v2.2 > mozilla-b2g:v2.2

This is the v2.2 version. I haven't tested it myself.
This is mozilla-b2g:v2.2 from mwargers:test_cost_control_data_alert_mobile.py_v2.2
Attachment #8576817 - Flags: review?(ctang)
Comment on attachment 8576817 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py_v2.2 > mozilla-b2g:v2.2

That's fantastic.
Attachment #8576817 - Flags: review?(ctang) → review+
Comment on attachment 8576709 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py > mozilla-b2g:master

Sorry I sat on this quite so long. It's just fine.
Attachment #8576709 - Flags: review?(gmealer) → review+
Keywords: checkin-needed
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
So I added the checkin-needed keyword and I reverted it directly, because I was afraid autolander would check in the wrong pull request. And it did :/
It checked in the second one, when I wanted it to check in the first one. Now, it's not a big deal, I think the second one can be checked in too, but now on the first pull request it still says:

Waiting to hear about d569ce4 — Autolander status is pending

Can I just merge it manually myself now, or do I have to wait for autolander?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Merged https://github.com/mozilla-b2g/gaia/pull/28845 myself now.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
could it also land on v2.1?
I don't see any reason not, someone should test that the pull request works there too, though.
Hi Martijn, could you help to uplift this patch to v2.1?
I already test it on my local for 10 times and results are all pass
Flags: needinfo?(martijn.martijn)
Comment on attachment 8585514 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py_v2.1 > mozilla-b2g:v2.1

Mike, this should be the v2.1 version. I haven't tested it myself, but I think it should work just fine there, too.
Flags: needinfo?(martijn.martijn)
Attachment #8585514 - Flags: review?(mlien)
Comment on attachment 8585514 [details] [review]
[gaia] mwargers:test_cost_control_data_alert_mobile.py_v2.1 > mozilla-b2g:v2.1

already local tested for 10 times and results are all pass, r+
Attachment #8585514 - Flags: review?(mlien) → review+
(In reply to Mike Lien[:mlien] from comment #17)
> Comment on attachment 8585514 [details] [review]
> [gaia] mwargers:test_cost_control_data_alert_mobile.py_v2.1 >
> mozilla-b2g:v2.1
> 
> already local tested for 10 times and results are all pass, r+

Merged it in the v2.1 branch.
You need to log in before you can comment on or make changes to this bug.