Closed Bug 1141451 Opened 5 years ago Closed 4 years ago

Homescreen is empty after flashing

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: shinglyu, Unassigned)

References

Details

Attachments

(1 file)

*** Description
Right after flashing, the homescreen is empty, no app is displayed. But we can still find and launch apps from the Rocket bar

*** Steps to Reproduce
1. Flash the pvt build (gaia + gecko)
2. Wait for the flashing process to finish and the phone restarted
 
*** Expected Results
The homescreen should show up and contains all the pre-installed apps

*** Actual Results
The homescreen is empty, no app is shown

*** Other Notes
We can still use the rocket bar to find apps like "phone" and launch it.

*** Reproduction Frequency
Often

*** Build
v2.2-FlameKK (Still bisecting the failing build)
Failing version:

  Full flash - Flame KK 

  Gaia-Rev        166491b92278dc9e648f8d49ab02d9ca00d74421
  Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ae4bcc9b5f2
  Build-ID        20150309162503
  Version         37.0
  Device-Name     flame
  FW-Release      4.4.2
  FW-Incremental  eng.cltbld.20150309.201258
  FW-Date         Mon Mar  9 20:13:09 EDT 2015
  Bootloader      L1TC000118D0
Attached image screenshot.png
Can you attach the logcat please?

I can think of at least 2 situations where this would happen : 
1) if the gecko/gaia is mismatched
2) if the webapps.json isn't set up to locate somewhere other than the system partition and it's not on the system partition.

You may also want to check where the webapps are located to see if they got properly installed on the device.
I'll get back with the logcat later.

The weird thing is that after rebooting the phone, everything gets back to normal. It only happens after flashing.
Flags: needinfo?(slyu)
I am unable to reproduce it right now. (I am flashing the pvt build 20150309162503) Let me check with others, some people in Taipei have the same problem, but we can't pinned down a certain build/combination that causes this.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.