Closed Bug 1141460 Opened 7 years ago Closed 3 years ago

[Flame][Browser]The browser will be closed when change the version of "m.soso.com".

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
tracking-b2g +
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: wangxin, Unassigned)

Details

Attachments

(4 files)

Attached video 430.mp4
[1.Description]:
[Flame][v2.2&v3.0][Browser]The browser will be closed when we visit "m.soso.com" and switch to another version of the page.
See video:"430.mp4"
See log:"logcat_430.txt"
Found time:"4:30"

[2.Testing Steps]: 
1. Launch Browser
2. Visit "m.soso.com"
3. Tap "极简版" in the page to switch to a simpler version.

[3.Expected Result]: 
3. The browser should display other version of this page correctly.

[4.Actual Result]: 
3. The browser is closed.

[5.Reproduction build]: 

Flame 2.2
Build ID               20150308002503
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a48af0b5a6e4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150308.052515
Firmware Date          Sun Mar  8 05:25:25 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:
Build ID               20150308160204
Gaia Revision          fea83511df9ccba64259346bc02ebf2c417a12c2
Gaia Date              2015-03-08 06:36:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab4a81e4457
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150308.192120
Firmware Date          Sun Mar  8 19:21:31 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Hi, SendKing,

It is likely to be Bug 1121871.

May I have your help?
Can we attach memory footprint chart here as we did on Bug 1121871 ( attachment 8549471 [details] )?

Many thanks.
Flags: needinfo?(wangxin)
From logcat: 
03-10 16:30:29.221 I/Gecko   (  209): IPDL protocol error: Handler for SetCookieString returned error code
03-10 16:30:29.221 I/Gecko   (  209): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x3A0003,name=PCookieService::Msg_SetCookieString) Processing error: message was deserialized, but the handler returned false (indicating failure)
03-10 16:30:29.231 I/Gecko   (  209): [Parent 209] WARNING: waitpid failed pid:2709 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 267
03-10 16:30:29.251 I/Gecko   (  209): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
03-10 16:30:29.301 I/Gecko   (  209): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
Is this a regression?
Keywords: qawanted
QA Contact: ychung
Attached image BrowserError.png
I was able to reproduce the issue on Flame 2.1.

Result: The browser closes when the user taps "极简版".

Environmental Variables:
Device: Flame 2.1
Build ID: 20150309232119
Gaia: 9f2f64bbc9f29edb36f8cbf57d4e0c3f4dee3124
Gecko: c78eec29e8c1
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

On Flame 2.0 and v18D-1 Base Image (2.0), the following dialog appears:

"Downloading /storage/sdcard/downloads/A0hjq1VR.part
/storage/sdcard/downloads/A0hjq1VR.part could not be saved, because the source file could not be read. 

Try again later, or contact the server administrator."

Then the notification "Download started" appears, followed by "Download failed". When the user presses "OK" on the dialog, the browser displays the error message:

"Well, this is embarrassing. We tried to display this Web page, but it's not responding."

See the attached screenshot.

Environmental Variables:
Device: Flame 2.0
Build ID: 20150309235619
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 9048a8b96b35
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi William,
Please see the memory footprint chart(picture "001.png") on attachment.
Thanks!
Flags: needinfo?(wangxin) → needinfo?(whsu)
(In reply to SandKing from comment #6)
> Created attachment 8575737 [details]
> memory footprint chart:001.png
> 
> Hi William,
> Please see the memory footprint chart(picture "001.png") on attachment.
> Thanks!

From the memory footprint chart, I am not sure why the Browser process was still alive.

My test result is Browser process was killed after I tapped "极简版 (Simple Version)" hyperlink.
Trying to launch browser app and tap the same link again, Browser will download a file (as comment 5 mentioned).

By using the same steps on Firefox OS desktop version, Firefox will download "index.jsp".
There seems to be something wrong with server response.

Anyway, I suggest to add a error handling to prevent this ERROR.
Thanks.
Flags: needinfo?(whsu)
[Blocking Requested - why for this release]:

A legacy bug. Suggest to fix on latest branch.
blocking-b2g: --- → 3.0?
Not blocking on low memory bugs.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → +
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.