Closed Bug 1141467 Opened 5 years ago Closed 5 years ago

[RTL][Search]The text of search suggestion prompt is not right-aligned.

Categories

(Firefox OS Graveyard :: Gaia::Search, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED DUPLICATE of bug 1129701
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: lulu.tian, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image search_suggestions.png
[1.Description]:
[RTL][v2.2&v3.0][Search]The text of search suggestions prompt which should be right-aligned is left-aligned.
See attachment:search_suggestions.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Search bar at homescreen for the first time.
3. Input "www" at search bar.
4. Observe the pop up prompt message.

[3.Expected Result]: 
4. The text in prompt message should be right-aligned.

[4.Actual Result]: 
4. The text is left-aligned.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150309002506
Gaia Revision          166491b92278dc9e648f8d49ab02d9ca00d74421
Gaia Date              2015-03-06 18:26:27
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/91b7aa6a3243
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.040114
Firmware Date          Mon Mar  9 04:01:25 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150309160227
Gaia Revision          4ef1fa9b2870499fc9c77cac4a15f62e12a3ad2c
Gaia Date              2015-03-09 02:53:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23f1f0369df5
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.192301
Firmware Date          Mon Mar  9 19:23:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Whiteboard: [systemsfe]
blocking-b2g: --- → 2.2?
We had this fixed in bug 1129701, but that got backed out. Marking as a dependency for now.
Depends on: 1129701
Priority: -- → P2
(In reply to Kevin Grandon :kgrandon from comment #1)
> We had this fixed in bug 1129701, but that got backed out. Marking as a
> dependency for now.

We just blocked on the 1129701 so hoping this get addressed as well.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → apastor
Fixed in bug 1129701
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129701
Attached image prompt_massage.png
Since the patch had landed on bug 1129701, this issue has been verified successfully on Flame v3.0
When search something via Rocket bar, the text in prompt message is right-aligned.
See attachment:prompt_massage.png
Rate:0/5

Flame 3.0 build: pass
Build ID               20150322160204
Gaia Revision          9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gaia Date              2015-03-22 10:09:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.192413
Firmware Date          Sun Mar 22 19:24:22 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Attached image v2.2_prompt_massage.png
Since the patch had uplifted on Flame 2.2 in Bug 1129701, this issue has been verified successfully on latest build of Flame 2.2
When search something via Rocket bar, the text in prompt message is right-aligned.
See attachment:v2.2_prompt_massage.png
Rate:0/5

Device: Flame 2.2(pass)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.