[Nexus 5] [Privacy Controls] Nexus 5 will crash when using Remote Protection

RESOLVED DUPLICATE of bug 1140111

Status

defect
RESOLVED DUPLICATE of bug 1140111
4 years ago
4 years ago

People

(Reporter: gchang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(1 attachment)

Reporter

Description

4 years ago
### Steps:
1. Open Settings app
2. Navigate to Privacy Controls > Remote Protection
3. Enter "1111" in both input fields
4. Press OK button

### Expected:
1. User should be directed to next page

### Actual:
1. Device will crash

### Reproduce rate
always

### Crash report
https://crash-stats.mozilla.com/report/index/a0349db4-7695-430b-8987-9cf932150310

### Version:
Gaia-Rev        166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ae4bcc9b5f2
Build-ID        20150309162503
Version         37.0
Device-Name     hammerhead
FW-Release      5.0
Reporter

Comment 1

4 years ago
This issue won't happen in flame.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Privacy Panel]
Whiteboard: [2.2-nexus-5-l]
Reporter

Comment 2

4 years ago
Posted file The crash log
(In reply to Gerry Chang [:cfchang] from comment #2)
> Created attachment 8575206 [details]
> The crash log

the crast stats info says this could be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1140111, so will wait for that uplift to see if the issue is fixed.

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Depends on: 1140111
Jed mentions in the other bug that he built it locally and it seems to fix the issue.  The patch landed today.  Could you retest, please?
Flags: needinfo?(gchang)
Reporter

Comment 5

4 years ago
Verified @ today's build
Gaia-Rev        4aefc3f6f30a40ac67fdf841b7c90cd648b85369
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/049713f3b0ed
Build-ID        20150313002507
Version         37.0
Device-Name     hammerhead
FW-Release      5.0

No more crash happened.
Flags: needinfo?(gchang)
close per comment 5
Status: NEW → RESOLVED
blocking-b2g: 2.2+ → ---
Last Resolved: 4 years ago
Resolution: --- → INVALID
Marking as a dup because the other bug mentioned that it fixed the issue and the crash signature shows that this could be related.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1140111
You need to log in before you can comment on or make changes to this bug.