Closed Bug 1141502 Opened 7 years ago Closed 6 years ago

YouTube: copying issues in HTML5 mode UI and "Stats for nerds"

Categories

(Firefox :: Untriaged, defect)

39 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: u123541, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150308030227

Steps to reproduce:

Right-click on HTML5 viewer and select an item.


Actual results:

1. several menu items, such as "Get video URL", return data (highlighted blue); but these can not be Copy'd and Paste'd because Copy does not replace whatever is in Copy buffer.  Linux workaround: double-click info and mouse-click paste.
2. Stats for nerds: unable to capture this data via either copy/paste method. Would require screen shot.


Expected results:

C&P should work
1. By "highlighted blue" you mean "looking selected". Somebody's bug indeed.
2. Must be a YouTube's problem.
Summary: html5 menu items → YouTube: copying issues in HTML5 mode UI and "Stats for nerds"
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1052569
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID 	20151228030213

Hi, 

I tested this on latest Nightly build (v.46) and Copy/Paste works fine for me. 
Also "Stats for nerds" data can be captured via copy/paste. Here are the steps I used: 
  1) Right click on the HTML5 youtube video 
  2) Click on "Stats for nerds" 
  3) I selected the data from "Stats for Nerds" 
  4) Right click for context menu to appear 
  5) Clicked "Copy" 
  6) Pasted on a new document. 
RESULT: Copy/Paste worked fine.

Pierre, can you confirm if this works for you as expected on latest Nightly version (currently v. 46 - https://nightly.mozilla.org/)?
Flags: needinfo?(pf)
All the items in the right-click menu that can be copied now work.
However, "Report playback issue" does not give user a chance to see what is about to be reported. It just went to https://support.google.com/youtube/answer/4456281?p=report_playback&rd=1 which provided no clue as to what was reported. Suspecting YouTube in this case might not be happy with these "reports"...
Flags: needinfo?(pf)
Thank you for your response. 

I tried to reproduce the "report playback issue" but worked for me. After clicking on "Report playback issue" I got a pop-up were I could write a description, after that I could take a screenshot and before submitting the bug I could see the bug description and the screenshot. So I was able to see what was about to be reported.

However, if this is an issue for you, and considering this bug is about copy/paste issue, would it not be better to close this one, and fill the "Report playback issue" in a new bug report with all steps to reproduce in place?
Flags: needinfo?(pf)
Maybe we see it differently...  that was not a "popup" here; it was the webpage mentioned in comment 4 which offers the abilities you describe.  Anyway, closing.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: needinfo?(pf)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.