Closed Bug 1141508 Opened 5 years ago Closed 5 years ago

xulrunner packaging broken on mozilla-beta mac builds

Categories

(Toolkit Graveyard :: XULRunner, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1137060

People

(Reporter: bhearsum, Unassigned)

Details

It worked in 37.0b3, but not b4. bug 1138535 looks likely to have caused it.
Flags: needinfo?(mshal)
/builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/rel-m-beta-xr_osx64_bld-000000/build/toolkit/mozapps/installer/informulate.py \
		../../dist/runtimes//xulrunner-37.0b4.en-US.mac.json \
		BUILDID=20150309191715 \
		MOZ_SOURCE_REPO=MOZ_SOURCE_REPO=https://hg.mozilla.org/releases/mozilla-beta \
		MOZ_SOURCE_STAMP=8065aad58fc2 \
		MOZ_PKG_PLATFORM=mac
cp ../../mozinfo.json ../../dist/runtimes//xulrunner-37.0b4.en-US.mac.mozinfo.json
Compressing...
cd ../../dist && (cd universal/xulrunner/XUL.framework/Contents/Resources && /builds/slave/rel-m-beta-xr_osx64_bld-000000/build/obj-firefox/i386/_virtualenv/bin/python /builds/slave/rel-m-beta-xr_osx64_bld-000000/build/config/createprecomplete.py) && gnutar -c --owner=0 --group=0 --numeric-owner --mode=go-w --exclude=.mkdir.done -f - -C universal/xulrunner XUL.framework | bzip2 -vf > runtimes/xulrunner-37.0b4.en-US.mac.tar.bz2
/bin/sh: line 0: cd: universal/xulrunner/XUL.framework/Contents/Resources: No such file or directory
make[3]: *** [make-package-internal] Error 1
make[2]: *** [make-package] Error 2
make[1]: *** [default] Error 2
make: *** [package] Error 2

Full log is at http://ftp.mozilla.org/pub/mozilla.org/xulrunner/candidates/37.0b4-candidates/build1/logs/release-mozilla-beta-xulrunner_macosx64_build-bm82-build1-build3.txt.gz
Looks like this was already notice on Nightly.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137060
Clearing needinfo since we chatted in IRC.
Flags: needinfo?(mshal)
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.