Closed Bug 1141516 Opened 5 years ago Closed 5 years ago

shell/futex.js permafail when pushing non-trunk branches to Try

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- unaffected
firefox38 --- fixed
firefox39 --- fixed

People

(Reporter: RyanVM, Assigned: lth)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1135368 +++

Looks like bug 1135368 isn't working. I'm seeing permafail on all non-trunk branches when I run SM jobs on them on Try.

https://treeherder.mozilla.org/logviewer.html#?job_id=5510143&repo=try

TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "")
TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --no-sse3 --no-threads")
TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "--ion-eager --ion-offthread-compile=off")
TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "--baseline-eager --no-fpu")
TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "--no-baseline --no-ion")
TEST-UNEXPECTED-FAIL | shell/futex.js | (args: "--baseline-eager")
Assignee: nobody → lhansen
The problem is that in the case of the early-out (non-Nightly), there is no call to reportCompare(), so the test driver gets upset.

The lack of a reportCompare() call probably came about because we don't need one in jit-test/, and we've gotten used to not worrying about it when writing guards for test cases.
I've reproduced the reported error on mozilla-inbound my manipulating config/milestone.txt, and I've verified that the attached patch then makes the error go away.
Attachment #8575309 - Flags: review?(luke)
Attachment #8575309 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/08f20332d65d
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.