READ_WRITE IDBTransaction creation causes Assertion failure: NS_HasPendingEvents(mThread) at dom/workers/WorkerPrivate.cpp:4830 when using IDB in service workers

RESOLVED DUPLICATE of bug 1132436

Status

()

RESOLVED DUPLICATE of bug 1132436
4 years ago
4 years ago

People

(Reporter: jaoo, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Note: This bug might be filed under the DOM:IndexedBD component as well I guess.

Latest m-i build with patch from bug 1137245 applied, enable both dom.serviceWorkers.enabled and dom.caches.enabled prefs.

Load the service worker demo at https://github.com/jaoo/service-worker-testing/tree/add-offliner which uses IDB and stores stuff in an IDB database.

Once the activate event gets fired the service worker stores stuff into the database and the crash reproduces.
Crash Signature: Assertion failure: NS_HasPendingEvents(mThread), at /Volumes/firefoxos/dev/mozilla-inbound/dom/workers/WorkerPrivate.cpp:4830 #01: mozilla::dom::indexedDB::IDBTransaction::Create(mozilla::dom::indexedDB::IDBDatabase*, nsTArray<nsString> const&, mozilla::…
See Also: → bug 1137245
DUP of bug 1132436?
See Also: → bug 1132436
Ben, could you please help on clarifying if this bug might be a duplicate of Bug 1132436?. Thanks!
Depends on: 1137245
Flags: needinfo?(bkelly)
See Also: bug 1137245
Sounds like it!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1132436
Flags: needinfo?(bkelly)
You need to log in before you can comment on or make changes to this bug.