If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Slow script warning on rpggeek.com. Make browser unusable.

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: hub, Assigned: juanb)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(e10s-)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Slow script warning on rpggeek.com. Make browser unusable.

Install today's nightly. Mac or Linux. With e10s enabled (not sure this is important though).

Open several tabs of random stuff.

Go to rpggeek.com 

I get the warning that Nightly is slow (top of the content). There is no "ignore" choice. It make the content not load properly on rpggeek. It also make the other content on other tab not work well.

This doesn't happen on older versions.
tracking-e10s: --- → ?
(Assignee)

Updated

3 years ago
Assignee: nobody → jbecerra
(Assignee)

Comment 1

3 years ago
Using the latest nightly Fx39 on Linux I can reproduce the problem easily by opening this bug, then opening rpggeek.com in a separate tab and waiting a few seconds.

You will see the a yellow notification bar with the options to stop script, debug script, or kill the web process.

If you do this on a non-e10s window you get an unresponsive script warning with the options to debug script, stop script, or continue.

Whatever the script is doing, it is affecting the nightly in e10s and non-e10s mode.

On release Fx36 the page loads fine.
Keywords: reproducible
(Assignee)

Comment 2

3 years ago
Created attachment 8575669 [details]
script warning in e10s
(Assignee)

Comment 3

3 years ago
Created attachment 8575670 [details]
script warning in non-e10s
(Assignee)

Comment 4

3 years ago
I'm removing the reproducible keyword because for a bit it was easily reproducible, and then it started loading the page, although with some errors and missing some of the content that shows fine in Fx36. Now it's back to being reproducible.
Keywords: reproducible
(Reporter)

Comment 5

3 years ago
I narrowed down the regression around 3f6b1ead121a which is the first of 7½ parts patch for bug 1113369 and 62fecc6ab96e which is the bustage fixer for said patch.

changeset:   232347:3f6b1ead121a
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Mon Feb 02 17:06:47 2015 -0600
summary:     Bug 1113369, part 1 - Introduce JS::ObjectOpResult and use it in js::StandardDefineProperty. r=Waldo.

changeset:   232348:48c2332309a0
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Wed Feb 18 18:49:17 2015 -0600
summary:     Bug 1113369, part 1½ - Avoid regressing error messages by adding obj to the ObjectOpResult methods that could throw a TypeError. r=Waldo.

changeset:   232349:da286f0f7a49
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Thu Jan 29 23:02:26 2015 -0600
summary:     Bug 1113369, part 2 - js::SetArrayLength ObjectOpResult support. r=Waldo.

changeset:   232350:2b18c04de86c
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Fri Jan 30 11:37:07 2015 -0600
summary:     Bug 1113369, part 3 - [[DefineOwnProperty]] ObjectOpResult support. r=Waldo, r=bz in dom, r=dvander in js/ipc, r=bholley in js/xpconnect.

changeset:   232351:0712a3d4b79c
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Tue Feb 03 19:51:40 2015 -0600
summary:     Bug 1113369, part 4 - [[Set]] ObjectOpResult support. r=Waldo, r=bz in dom, r=dvander in js/ipc, r=bholley in js/xpconnect.

changeset:   232352:35f7c0795116
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Wed Feb 04 10:20:04 2015 -0600
summary:     Bug 1113369, part 5 - [[Delete]] ObjectOpResult support. r=Waldo, r=bz in dom, r=dvander in js/ipc, r=bholley in js/xpconnect.

changeset:   232353:e85721e91692
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Wed Feb 04 12:01:01 2015 -0600
summary:     Bug 1113369, part 6 - [[PreventExtensions]] ObjectOpResult support. r=Waldo, r=bz in dom, r=dvander in js/ipc, r=bholley in js/xpconnect.

changeset:   232354:41df9affe00f
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Thu Feb 05 16:36:50 2015 -0600
summary:     Bug 1113369, part 7 - [[SetPrototypeOf]] ObjectOpResult support. r=Waldo, r=bz in dom, r=dvander in js/ipc, r=bholley in js/xpconnect.

changeset:   232355:e9c646b6392f
user:        Monica Chew <mmc@mozilla.com>
date:        Thu Mar 05 10:54:23 2015 -0800
summary:     Bug 1090754: Re-enable remote-lookups in release builds (r=sworkman,francois)

changeset:   232356:cf124d9e2441
user:        Monica Chew <mmc@mozilla.com>
date:        Thu Mar 05 11:55:03 2015 -0800
summary:     Bug 1134954: Disable Safe Browsing in safe mode (r=francois,sworkman)

changeset:   232357:94a0946d5a0a
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Fri Mar 06 16:33:30 2015 -0500
summary:     Bug 1131802 part 1.  Add JS friend API to test whether a given function object has extended slots.  r=terrence

changeset:   232358:fdb146bc4052
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Fri Mar 06 16:33:31 2015 -0500
summary:     Bug 1131802 part 2.  Allocate functions with reserved slots for DOM Xrays so we can store the Xray wrapper reference in those slots instead of as the function parent.  r=peterv

changeset:   232359:41846743ab88
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Fri Mar 06 16:33:31 2015 -0500
summary:     Bug 1131805 part 2.  Remove remaining js::GetObjectParent and JS_GetParent uses in SpiderMonkey.  r=waldo

changeset:   232360:62fecc6ab96e
user:        Jason Orendorff <jorendorff@mozilla.com>
date:        Fri Mar 06 20:24:39 2015 -0600
summary:     Fix JSErr_Limit, broken by rev 41df9affe00f. No bug, r=red.
(Reporter)

Updated

3 years ago
Keywords: regression

Updated

3 years ago
tracking-e10s: ? → -
(Reporter)

Comment 6

3 years ago
With Nightly from 2015-03-24 *on Mac* I can't reproduce anymore.
(Reporter)

Updated

3 years ago
Component: General → XPConnect
Product: Firefox → Core
(Reporter)

Comment 7

3 years ago
not sure it is the right component but it surely can't be worse than the other one. I was suggested this one. If you have a better idea, please. Also if you know the dupe bug, feel free.
Are you still seeing this?  There were a bunch of regressions from bug 1113369 that could lead to behavior like this, but they have since been fixed.  Comment 6 suggests that this was in fact fixed by one of those fixes...
Component: XPConnect → JavaScript Engine
Flags: needinfo?(hub)
(Reporter)

Comment 9

3 years ago
yes this works in the current m-i on Linux and Nightly on Mac.

Thanks.
Flags: needinfo?(hub)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.