Redesign mozilla.org site navigation and appearance

RESOLVED FIXED

Status

www.mozilla.org
General
--
enhancement
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: Dawn Endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Its boring how the Mozilla website never changes. It needs some pizazz when 
M1.0 comes out. Some kind of new look. Maybe it should look a little more like 
the modern theme. I don't know what - but it needs something.
(Reporter)

Updated

16 years ago
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 1

16 years ago
This style should carry over to b.m.o

Comment 2

16 years ago
hmmm... yes. a new look would be quite refreshing =) first of all priority
should be set on HTML/Strict imho. then we should have something showing off
mozillas capabilities while remaining functionality of the site. still all
something quite easy achievable by means of CSS. well *g* this give one
inspiration, doesn't it? maybe i'll just play around a litte and if something
cool happens, and a new exciting design comes creeping out of my mind - i'll let
you know. but even if it does not: we should be aiming towards HTML/strict
compliance.

Comment 3

16 years ago
-> taking QA contact so I don't need to watch Dawn anymore. ;)
QA Contact: endico → imajes

Comment 4

16 years ago
*** Bug 140086 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
The bug I duped to this, 140086, also suggests that the download link for the
latest release could be a bit more discoverable. I agree.
(Reporter)

Comment 6

16 years ago
Daniel Steinberger: If someone is using NS 2.0 and wants to go download Mozilla,
then they should still be able to view that page. Therefore, I don't think
strict compliance is a good thing to shoot for unless we have an alternative
page for older browsers.

Comment 7

16 years ago
If I might add my two cents - I think the page should be as simple as possible -
don't allow a desire to show off Mozilla's features get in the way of usability.
 Personally I think that Google provides a good example of usability for a
website - just as complex as it needs to be, and not an iota more.

Comment 8

16 years ago
i'm not telling that demonstrating mozilla's power should prevent people using
NS2.0 from visiting the page. but even NS2.0 renders HTML4.01/strict documents
absolutly correct. that's the point. have you visited
http://www.meyerweb.com/eric/css/edge/ with NS4.x or lower? then you would
understand that using STRICT html does in no way prevent older browsers from
displaying the page absolutly correct. this means: without stylesheets applied.
and i'm aware of http://www.mozilla.org.uk/temp/start/1.0/ which in fact USES
the STRICT doctype. and i'm pretty pleased with this page. so my wish is
fulfilled. =)

Comment 9

16 years ago
well.. correct me, if i'm wrong, but this event has passed so long ago, and i
think this is a wontfix now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

15 years ago
The event has passed, but the need for a redesign hasn't. Reopening.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: mozilla.org site needs a new look for Mozilla 1.0 → Redesign mozilla.org site navigation and appearance
(Reporter)

Comment 11

15 years ago
Assigning to Brant because he has expressed interest on the newsgroups for
fixing this.
Assignee: endico → brantgurganus2001
Status: REOPENED → NEW
QA Contact: imajes → endico

Comment 12

15 years ago
My current design(s) and accompanying stylesheet are at the URL provided. 
Please provide feedback in the appropriate thread in
netscape.public.mozilla.documentation.  I'm currently downloading NS 4.8 to
hammer out the NS4 issues to make people happy.
Status: NEW → ASSIGNED

Comment 13

15 years ago
reverting to default owner
Assignee: brantgurganus2001 → endico
Status: ASSIGNED → NEW
QA Contact: endico → imajes

Comment 14

15 years ago
with the new design landed today, is this issue fixed?
(Reporter)

Comment 15

15 years ago
Definately! :-)
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.