Closed Bug 1141806 Opened 5 years ago Closed 5 years ago

[Music][Search] When plugging and unplugging the device, the keyboard will remain active in music and allow the user to shift the page by typing

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: dharris, Assigned: dkuo)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
The Music app will leave the keyboard open when plugging the device in and having the USB sharing page overlay on the device. If the user types into the keyboard while this happens, the page will shift to the left of the screen. The user can recover by tapping on any visible button of the music app, or the home button.

Prerequisite: Have USB sharing enabled and at least 1 song in the music app

Repro Steps:
1) Update a Flame to 20150309160227
2) Open Music app
3) Change the view to any view except the grid view
4) Swipe down to show search bar, ensure the keyboard is active
5) Plug in the device> observe keyboard
6) Type a few characters
7) Unplug Device
 

Actual:
The keyboard remains active when plugging in the device, when typing the page gets shifted over to the left


Expected:
The keyboard does not remain active when plugging in the device and if it does, the search will occur under the USB overlay screen

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150309160227
Gaia: 4ef1fa9b2870499fc9c77cac4a15f62e12a3ad2c
Gecko: 23f1f0369df5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Video - http://youtu.be/D0uO7Hcrj1I 

I was unable to get a logcat, as this bug requires the user to unplug the device
This issue DOES occur on Flame 2.2, 2.1, 2.0 and Flame base v18D-1

The keyboard remains active when plugging in the device, when typing the page gets shifted over to the left

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150309002506
Gaia: 166491b92278dc9e648f8d49ab02d9ca00d74421
Gecko: 91b7aa6a3243
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150309001219
Gaia: ea97a87048a4c1e2a479bbea1d75e0a182b2c4c9
Gecko: 0443f2e951dc
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150309000203
Gaia: 8463d1c9142f32c8ea175048dac52e41620443ce
Gecko: 9399de0723a0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame Base v18D-1
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(npark)
I initially thought it is a pretty rare use case, but looking at the video, once it happens it looks pretty bad. Hema, should we nom this bug for 2.2?
Flags: needinfo?(npark) → needinfo?(hkoka)
Blocking Reason: Though it can be recovered back easily with a tap, very poor user experience with keyboard lingering around with half of the screen shifting to one end as the user is typing. 

Jim,

Could you do a quick check on this after your other music/ringtone blockers are addressed? 

Thanks
Hema
blocking-b2g: --- → 2.2+
Flags: needinfo?(hkoka) → needinfo?(squibblyflabbetydoo)
I checked this bug quickly and found it takes few lines to get it fixed, so taking it with a quick patch.
Assignee: nobody → dkuo
Flags: needinfo?(squibblyflabbetydoo)
Attachment #8577942 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8577942 [details] [review]
[gaia] dominickuo:bug-1141806 > mozilla-b2g:master

Looks good! (Note: I didn't test this patch manually.)
Attachment #8577942 - Flags: review?(squibblyflabbetydoo) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8577942 [details] [review]
[gaia] dominickuo:bug-1141806 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): a new bug we didn't find before.
[User impact] if declined: bad ux if we don't dismiss the keyboard.
[Testing completed]: yes, test is already included in the keyboard tests.
[Risk to taking this patch] (and alternatives if risky): low.
[String changes made]: none.
Attachment #8577942 - Flags: approval-gaia-v2.2?
Attachment #8577942 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The keyboard does not stay on the screen when the device is plugged in.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.